This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 115787 - warnings about unknown user "bhcompile" during install of samba-common
warnings about unknown user "bhcompile" during install of samba-common
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-16 01:27 EST by James Henstridge
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.0.2a-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 16:37:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Henstridge 2004-02-16 01:27:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-AU; rv:1.6)
Gecko/20040113

Description of problem:
When installing the 3.0.2-5 samba packages, warnings are generated
about the user and group "bhcompile" not existing.

Version-Release number of selected component (if applicable):
3.0.2-5

How reproducible:
Always

Steps to Reproduce:
1.install samba 3.0.2 RPMs


Actual Results:  The following warnings are printed:
  warning: user bhcompile does not exist - using root
  warning: group bhcompile does not exist - using root
  warning: user bhcompile does not exist - using root
  warning: group bhcompile does not exist - using root


Expected Results:  No warnings should be printed (the directories
should be owned by root anyway, so this is not a very big problem).

Additional info:

# rpm -qvl samba-common | grep bhcomp
drwxr-xr-x  2 bhcompilbhcompil  0 Feb 10 04:15 /usr/lib/samba
drwxr-xr-x  2 bhcompilbhcompil  0 Feb 10 04:18 /usr/lib/samba/charset

Looks like a trivial packaging bug.
Comment 1 James Henstridge 2004-02-16 21:51:31 EST
This bug appears to be fixed in the 3.0.2-7.FC1 package released as an
update for Fedora Core 1.  I guess that means it will be fixed in
devel as well soon.
Comment 2 Jay Fenlason 2004-02-24 16:37:31 EST
Fixed in 3.0.2a-1

Note You need to log in before you can comment on or make changes to this bug.