Bug 115792 - Default profile interface configuration out-of-sync
Summary: Default profile interface configuration out-of-sync
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rcn-profiling
TreeView+ depends on / blocked
 
Reported: 2004-02-16 07:37 UTC by Dax Kelson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 19:10:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2004-02-16 07:37:54 UTC
Description of problem:

This problem has existed ever since RHL8/9. I teach Linux classes and
students get bitten by this all the time.

When system|redhat-config-network is first launched it creates files
in the /etc/sysconfig/networking/profiles/default/ directory. If you
then *save* and exit the tool, it hard links them to the
/etc/sysconfig/network-scripts files.

If a person launches the tool and then exits (without making changes
and saving), then the "default" profile interface files are
out-of-synce with the files in /etc/sysconfig/network-scripts/.

The "search path" for ifup/ifdown has the default profile before the
/etc/sysconfig/network-scripts directory, so when changes are made in
the "standard" location with a text editor the changes don't seem to
take effect.

This can be easily observed.

On a freshly installed system I launch system|redhat-config-network.

# ls -i /etc/sysconfig/network-scripts/ifcfg-eth0
20772 /etc/sysconfig/network-scripts/ifcfg-eth0

# ls -i /etc/sysconfig/networking/profiles/default/ifcfg-eth0
16879 /etc/sysconfig/networking/profiles/default/ifcfg-eth0

Note how the inode numbers are different. The files are different.

Now if I do File -> Save, and then check the inode numbers:

# ls -i /etc/sysconfig/network-scripts/ifcfg-eth0
16879 /etc/sysconfig/network-scripts/ifcfg-eth0

# ls -i /etc/sysconfig/networking/profiles/default/ifcfg-eth0
16879 /etc/sysconfig/networking/profiles/default/ifcfg-eth0

You can see it is the same file.

When I lecture my classes I currently tell my students, "if you decide
to launch the system|redhat-config-network utility to see what it
looks like make sure you *save* (even though they haven't changed
anything) otherwise your /etc/sysconfig/network-scripts will be
ignored by ifup/ifdown".

Please fix system|redhat-config-network. I can think of a couple ways.

1) Don't create the default profile files until a "save" is done. Then
make them as hard links from the begining. This seems best to me as it
seems a little odd for the tool to perform *any* changes in /etc just
by merely launching it.

2) Create the files as hard links from the very begining.

Comment 1 Harald Hoyer 2004-02-16 09:11:24 UTC
>> The "search path" for ifup/ifdown has the default profile before the
>> /etc/sysconfig/network-scripts directory, so when changes are made
>> in the "standard" location with a text editor the changes don't seem 
>> to take effect.

This is wrong... the initscripts should not look in
/etc/sysconfig/networking!!

reassigning

Comment 2 Dax Kelson 2004-02-16 17:31:54 UTC
Are you sure? Doesn't that then break network profiles?

search path for:
# ifup $DEV
is:
/etc/sysconfig/networking/profiles/$CURRENT_PROFILE/ifcfg-$DEV
/etc/sysconfig/networking/profiles/default/ifcfg-$DEV
/etc/sysconfig/network-scripts/ifcfg-$DEV

Seems they *have* to look in /etc/sysconfig/networking.

Comment 3 Bill Nottingham 2004-02-16 19:04:41 UTC
> This is wrong... the initscripts should not look in
> /etc/sysconfig/networking!!

They don't.


Comment 4 Dax Kelson 2004-09-04 19:10:15 UTC
The original problem 

"If a person launches the tool and then exits (without making changes
and saving), then the "default" profile interface files are
out-of-synce with the files in /etc/sysconfig/network-scripts/."

Is fixed. 

I tested rawhide from today (FC2test3??).


Note You need to log in before you can comment on or make changes to this bug.