Bug 1157999 - [RFE] Add keystone URL for OpenStack external providers that require authentication.
Summary: [RFE] Add keystone URL for OpenStack external providers that require authenti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Eli Mesika
QA Contact: Ondra Machacek
URL: http://www.ovirt.org/Features/Design/...
Whiteboard:
: 1019616 1061131 (view as bug list)
Depends On:
Blocks: 1063716 1253562
TreeView+ depends on / blocked
 
Reported: 2014-10-28 08:55 UTC by Eli Mesika
Modified: 2016-03-09 20:50 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, all OpenStack external providers like Neutron and Glance used the same Keystone authentication URL stored in the KeystoneAuthUrl configuration value. Now, a URL field has been added to provider configuration so that different OpenStack providers can use different Keystone authentication URLs.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:50:02 UTC
oVirt Team: Infra
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 34880 master MERGED core: add keystone url field to external providers Never

Description Eli Mesika 2014-10-28 08:55:05 UTC
Description of problem:

Currently, all OpenStack external providers like Neutron and Glance are using the same Keystone authentication URL stored in the KeystoneAuthUrl configuration value. The requirement is to add a URL field per such provider for setting that URL and enable different OpenStack providers using diffrent Keystone authentication URLs 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

http://www.ovirt.org/Features/Design/AddingKeystoneURLToExternalProviders

Comment 1 Oved Ourfali 2015-04-06 08:38:28 UTC
*** Bug 1019616 has been marked as a duplicate of this bug. ***

Comment 2 Oved Ourfali 2015-04-14 11:31:16 UTC
*** Bug 1061131 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2016-03-09 20:50:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.