Bug 115801 - Matrox MilleniumII suggest only 800x600
Matrox MilleniumII suggest only 800x600
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 04:38 EST by Daniel Veillard
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Veillard 2004-02-16 04:38:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
On Fedora Core 2 beta 1
The Matrox MilleniumII card get only proposed 
resolutions 640x480 and 800x600
The XFree86 part works fine at 1600x1200 once
the XF86Config file is overriden with an older version
from FC1

Daniel

Version-Release number of selected component (if applicable):
system-config-display-1.0.4-1

How reproducible:
Always

Steps to Reproduce:
1.Install FC2 beta1
2.Check resolution
3.Look on the desktop settings highest proposed is 800x600
    

Additional info:
Comment 1 Brent Fox 2004-02-19 18:42:39 EST
Is the monitor being correctly probed by ddcprobe?
Comment 2 Daniel Veillard 2004-02-23 08:12:51 EST
yes, I think that was okay (Vision Master Pro 21" Iiyama)
'cause that's the first think I though might have failed.

Daniel
Comment 3 Brent Fox 2004-02-25 11:14:33 EST
Hmm...can you post the results of the ddcprobe?

The reason I ask is because we fall back to some safe defaults for
monitors that can't be probed (640x480 and 800x600).  If you go to the
hardware tab and manually select the right monitor, the list of
resolutions will change to reflect the capabilities of that selection.
 If that's not the case here, then I don't know what could be wrong. 
Almost none of that code has changed since FC1.
Comment 4 Daniel Veillard 2004-02-25 11:47:03 EST
As root I get 

[root@localhost root]# ddcprobe
                                                                     
          
Videocard DDC probe results
Description:  Matrox MISTRAL
Memory (MB):  2
                                                                     
          
Monitor DDC probe results
ID: IVM2130
Name: Iiyama MT-9021E/T, VisionMasterPro
Horizontal Sync (kHZ): 24-94
Vertical Sync (HZ)  : 50-160
Width (mm): 400
Height(mm): 300
[root@localhost root]#

 The values returned seems accurate.
 As an user it fails, that's probably normal though:

localhost:~ -> ddcprobe
                                                                     
          
Monitor DDC probe results
Monitor DDC Probe failed.
localhost:~ ->

  Running the gui configuration tool, the hardware (card Matrox
Millenium II, VisionMasterPro 21) is correctly detected. Now it
offers 4 resolutions (1152, 1024, 800, 640) though the monitor/card
combo has been running 1600x1200 happily, even on FC2 beta1 ...

  I hope this helps ...

Daniel
Comment 5 Brent Fox 2004-03-25 16:08:16 EST
I can't believe that a 2MB video card can do 1600x1200 in anything
other than 8 bit color.  I've put a 2MB Matrox Mystique in my test
machine and when I try to do anything over 800x600 with 16 bit color
or more, xorg-x11 gives an error that it needs at least 4608 kB of
video memory to do that resolution and bit depth.

The list of available resolutions comes from rhpl in the xhwstate.py
file in the available_resolutions() function.  It tries to create a
list of resolutions that makes sense for video cards of various memory
sizes.  It's impossible to correctly guess all available modes for all
video card/monitor combination and get it completely right.  

I'm going to change the component of this bug to rhpl and assign it to
katzj.  I would recommend closing this as 'notabug' since I think the
code in availabe_resolutions() gets it right about as often as can be
expected.

Comment 6 Daniel Veillard 2004-03-25 16:19:16 EST
well dccprobe is just wrong, I think that card has 4MB
From the /var/log/XFree86.0.log (where it's running 1600x1200x16bpp)
(--) PCI:*(0:9:0) Matrox Graphics, Inc. MGA 2164W [Millennium II] rev
0, Mem @ 0xcd000000/24, 0xcfffc000/14, 0xcf000000/23, BIOS @ 0xcffe0000/16
[...]
(--) MGA(0): VideoRAM: 4096 kByte

Daniel
Comment 7 Mark Rudnicki 2004-07-12 23:24:55 EDT
I had the same problem with my Matrox Millenium II in FC1 and I
continue to have this problem in FC2 after doing a fresh installation.
 I'm absolutely sure that My Millenium II has 4MB of memory but
dccprobe is reporting that it only has 2MB.
Comment 8 Luka Birsa 2004-10-13 15:31:17 EDT
I have the same problem, running FC2, after a clean install i can't
get any higher resolutions than 800x600. 

Im sure, that I can run in 1024x768 using millions of colors, but
setup does not provide that resolution. Im using an LCD screen,
DDCPROBE did get the specs right - but to avoid problems I did try a
1024x768 generic LCD - it didn't do any good.

Is there a way to force a resolution in FC2 (im a n00b when it comes
to linux).
Comment 9 Bill Nottingham 2005-09-23 16:58:02 EDT
Closing bugs on older, no longer supported releases. Apologies for any lack of
response.

Please attempt to reproduce this bug on a currently supported release, such as
Fedora Core 4. If it persists, please open a new bug in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.