Bug 1158044 - [3.4-6.6] Can't reinstall RHEVH successful on physical machine-Grub Installation Failed
Summary: [3.4-6.6] Can't reinstall RHEVH successful on physical machine-Grub Installat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1032420 (view as bug list)
Depends On: 1136966 1148979
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-28 12:17 UTC by haiyang,dong
Modified: 2016-02-10 20:06 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:05:17 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
attached ovirt.log from /tmp of rhev-hypervisor6-6.6-20141007.0.iso (125.16 KB, text/plain)
2014-10-28 12:22 UTC, haiyang,dong
no flags Details
attached logs for from /var/log of rhev-hypervisor6-6.6-20141007.0.iso (430.00 KB, application/x-tar)
2014-10-28 12:22 UTC, haiyang,dong
no flags Details
also attached ovirt.log from /tmp of rhev-hypervisor6-6.6-20141029.0.iso (152.05 KB, text/plain)
2014-10-29 09:18 UTC, haiyang,dong
no flags Details
also attached logs from /var/log of rhev-hypervisor6-6.6-20141029.0.iso (380.00 KB, application/x-tar)
2014-10-29 09:20 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 34561 master MERGED Log system() failures in ovirtfunctions Never
oVirt gerrit 34611 master MERGED Log debug information if /liveos can't be mounted Never
oVirt gerrit 34676 master MERGED Also dd GPT labels Never
oVirt gerrit 34681 master ABANDONED Try to translate candidate_dev Never
oVirt gerrit 34781 master MERGED Use parted to rewrite the disklabel Never
oVirt gerrit 34792 master MERGED patch udev rules to wait for triggering Never
oVirt gerrit 34801 node-3.0 MERGED patch udev rules to wait for triggering Never
oVirt gerrit 35160 master MERGED recipe: Fix udev patch Never
oVirt gerrit 35175 node-3.0 MERGED recipe: Fix udev patch Never
oVirt gerrit 35490 node-3.0 MERGED Use parted to rewrite the disklabel Never
oVirt gerrit 35491 node-3.0 MERGED Also dd GPT labels Never

Description haiyang,dong 2014-10-28 12:17:37 UTC
Description of problem:
Can't reinstall rhev-hypervisor6-6.6-20141027.0.iso via pxe on physical machine-  Exception: RuntimError('Failed to set install bootloader',) appears at 80% of installation.

2014-10-27 12:10:27,004 - DEBUG - ovirtfunctions - 
2014-10-27 12:10:27,004 - DEBUG - install - 
    grub --device-map=/liveos/grub/device.map <<EOF
root (hd0,2)
setup --prefix=/grub (hd0)
EOF

2014-10-27 12:10:27,041 - DEBUG - install - 

    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]
grub> root (hd0,2)
 Filesystem type is ext2fs, partition type 0x83
grub> setup --prefix=/grub (hd0)
 Checking if "/grub/stage1" exists... no

Error 15t: File not found
grub> 
2014-10-27 12:10:27,041 - ERROR - install - GRUB setup failed
2014-10-27 12:10:27,041 - ERROR - install - Grub Installation Failed 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.6-20141027.0.iso 
ovirt-node-3.0.1-19.el6.21.noarch.rpm

How reproducible:
20%

Steps to Reproduce:
1.Boot rhev-hypervisor6-6.6-20141027.0.iso from pxe server
2.Choose reinstall rhev-hypervisor6-6.6-20141027.0.iso on physical machine

Actual results:
Sometimes reinstall this iso failed in "set install bootloader"

Expected results:
reinstall rhev-hypervisor6-6.6-20141027.0.iso via pxe on physical machine success

Additional info:

Comment 1 haiyang,dong 2014-10-28 12:22:05 UTC
Created attachment 951369 [details]
attached ovirt.log from /tmp of rhev-hypervisor6-6.6-20141007.0.iso

Comment 2 haiyang,dong 2014-10-28 12:22:51 UTC
Created attachment 951370 [details]
attached logs for from /var/log of rhev-hypervisor6-6.6-20141007.0.iso

Comment 4 Ryan Barry 2014-10-28 17:19:56 UTC
I've also tried to reproduce this 25 times with PXE.

25 dirty reinstall attempts with CD. No reproducers.
25 dirty reinstall attempts with PXE. No reproducers.

Please provide as much detail as possible on how to reproduce this. Kernel arguments, method used, how many installs have occurred previously, etc.

An sosreport may even be helpful at this point.

Comment 7 haiyang,dong 2014-10-29 09:18:58 UTC
Created attachment 951682 [details]
also attached ovirt.log from /tmp of rhev-hypervisor6-6.6-20141029.0.iso

Comment 8 haiyang,dong 2014-10-29 09:20:08 UTC
Created attachment 951684 [details]
also attached logs from /var/log of rhev-hypervisor6-6.6-20141029.0.iso

Comment 16 Zdenek Kabelac 2014-10-29 21:34:27 UTC
Use  'lsblk'  to see who holds /dev/sda3 device
(i.e. it could be possibly used as PV)?

Comment 31 Fabian Deutsch 2014-11-04 09:51:04 UTC
This bug can now be reproduced in one out of 10 trials (10%).

Comment 32 Fabian Deutsch 2014-11-04 10:26:55 UTC
(In reply to Fabian Deutsch from comment #31)
> This bug can now be reproduced in one out of 10 trials (10%).

This was incorrect, let me clarify below.

(In reply to haiyang,dong from comment #30)

...

> > 
> > Third is writing an msdos disklabel, then a GPT disklabel:

..

> Sometimes reinstall this iso via pxe in dirty disk still failed in Grub
> Installation Failed issue.
> See ovirt-20141103.0.third.log from ovirt-log.tar to check

THIS build is lowering the reproducability to 10%.

Comment 36 Fabian Deutsch 2014-11-06 16:02:14 UTC
*** Bug 1032420 has been marked as a duplicate of this bug. ***

Comment 37 haiyang,dong 2014-11-07 09:11:29 UTC
This bug has been fixed in rhevh 6.6 for RHEV 3.4.z bulid version:
rhev-hypervisor6-6.6-20141106.1.iso
ovirt-node-3.0.1-19.el6.22

dirty reinstall rhev-hypervisor6-6.6-20141106.1.iso with PXE in FC/ISCSI/CCISS/Local storage machine, No reproducers.

Comment 38 Ying Cui 2014-11-11 09:12:42 UTC
This bug target is 3.5, so need this issue to fix in rhevh for rhev 3.4.z as well.

Comment 39 haiyang,dong 2014-11-11 10:35:38 UTC
Also this bug has been fixed in rhevh 6.6 for RHEV 3.5 bulid version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

dirty reinstall rhev-hypervisor6-6.6-20141107.0.iso with PXE in FC/ISCSI/CCISS/Local storage machine, No reproducers.

According to Comment 37 and Comment 39, so this bug has been fixed, change the status into "VERIFIED".

Comment 44 errata-xmlrpc 2015-02-11 21:05:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.