Bug 1158049 - [engine-backend] Image remains in LOCKED state after a failure to live migrate it due to CDA block
Summary: [engine-backend] Image remains in LOCKED state after a failure to live migrat...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: lkuchlan
URL:
Whiteboard: storage
Depends On: 1105846
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-28 12:35 UTC by Elad
Modified: 2016-02-10 17:05 UTC (History)
13 users (show)

Fixed In Version: ovirt-engine-3.5.0_vt10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 13:42:56 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
engine.log and vdsm.log (1.51 MB, application/x-gzip)
2014-10-28 12:35 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34612 master MERGED core: Check live snapshot capabilities in live storage migration CDA Never
oVirt gerrit 34841 ovirt-engine-3.5 MERGED core: Check live snapshot capabilities in live storage migration CDA Never

Description Elad 2014-10-28 12:35:21 UTC
Created attachment 951371 [details]
engine.log and vdsm.log

Description of problem:
Live storage migration failed because live snapshot is not supported for the host as reported here https://bugzilla.redhat.com/show_bug.cgi?id=1158043.
After the failure, the image remains stuck in status LOCKED.

Version-Release number of selected component (if applicable):
rhev3.5 vt7
RHEL6.6 host
rhevm-3.5.0-0.17.beta.el6ev.noarch
libvirt-0.10.2-46.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
On a setup with a DC with more than 1 storage domaim from the same type (block/file)
1. Add a RHEL6.6 host with the mentioned qemu-kvm-rhev version to RHEVM, check that it does not support live snapshot
2. Create a VM with disk attached on one domain
3. Try to live migrate the disk to the second domain

Actual results:
The LSM fails:

2014-10-28 13:51:07,579 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (org.ovirt.thread.pool-7-thread-2) [3fe078e6] Running command: LiveMigrateVmDisksCommand Task handler: LiveSnapshotTaskHandle
r internal: false. Entities affected :  ID: 0ad5eaa4-d093-4bcc-9177-d8404ae7d1b1 Type: DiskAction group CONFIGURE_DISK_STORAGE with role type USER,  ID: a727ba52-c7f5-4810-8368-7f30acbe3d31 Type: StorageAction gro
up CREATE_DISK with role type USER
2014-10-28 13:51:07,816 INFO  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (org.ovirt.thread.pool-7-thread-2) Command 7858b8a4-61ff-4ec3-bbb9-2a8b182114ed persisting async task placeholder for child
 command bf919c39-61d4-46d8-ab4d-c9c705ee31f2
2014-10-28 13:51:08,460 WARN  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (org.ovirt.thread.pool-7-thread-2) CanDoAction of action CreateAllSnapshotsFromVm failed. Reasons:VAR__ACTION__CREATE,VAR__
TYPE__SNAPSHOT,ACTION_TYPE_FAILED_QEMU_UNSUPPORTED_OPERATION
2014-10-28 13:51:08,504 INFO  [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (org.ovirt.thread.pool-7-thread-2) Removed task 54747a1e-185f-4506-b190-bada2d1d3d84 from DataBase
2014-10-28 13:51:08,509 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (org.ovirt.thread.pool-7-thread-2) Lock freed to object EngineLock [exclusiveLocks= key: 0ad5eaa4-d093-4bcc-9177-d8404ae7d1b1
 value: DISK

But the disk remains in status LOCKED:

              image_guid              | imagestatus
--------------------------------------+-------------
 30c67d71-1fa9-4983-b4cc-f468702725d2 |           2



Expected results:
Disk should move to status OK after a failure to live migrate it

Additional info: engine.log and vdsm.log

Comment 1 Tal Nisan 2014-10-29 13:42:56 UTC

*** This bug has been marked as a duplicate of bug 1149460 ***

Comment 2 Elad 2014-10-29 14:28:52 UTC
This is not the same scenario. Please read description. The image remains in LOCKED state after engine blocked the LSM on CDA.

Anyway, the other bug was verified based on the same vdsm build this bug was opened with:


[reply] [−]
Private
Comment 24 Nikolai Sednev 2014-10-28 10:17:09 EDT

Works for me on these components:
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64
libvirt-0.10.2-46.el6_6.1.x86_64
vdsm-4.16.7.1-1.el6ev.x86_64
sanlock-2.8-1.el6.x86_64

Comment 3 Elad 2014-10-29 14:31:11 UTC
On my host:

[root@green-vdsb ~]# rpm -q vdsm
vdsm-4.16.7.1-1.el6ev.x86_64

Comment 4 Elad 2014-10-29 14:33:47 UTC
The security flag was set by mistake. It will be removed

Comment 5 Allon Mureinik 2014-10-30 13:50:08 UTC
oVirt bug 1105846 should handle this, leaving this one open for verification on RHEV.

Anyway, reducing priority to low - once bug 1149460 is solved, this problem can never happen anyway.

Comment 6 lkuchlan 2014-11-26 16:37:53 UTC
The LSM process completed successfully, and the disk status was set back to "OK"
Verified on VDSM vt11

Comment 7 Allon Mureinik 2015-02-16 19:13:36 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 8 Allon Mureinik 2015-02-16 19:13:36 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.