Bug 115807 - gnome-vfs2-smb file list is wrong
gnome-vfs2-smb file list is wrong
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-16 05:27 EST by Gary Peck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 04:31:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Peck 2004-02-16 05:27:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
gnome-vfs2-smb contains:
/etc/gnome-vfs-2.0/modules/ssl-modules.conf
/usr/lib/gnome-vfs-2.0/modules/libsmb.so

the first file should instead be in gnome-vfs2, and gnome-vfs2-smb
should contain /etc/gnome-vfs-2.0/modules/smb-module.conf.

Version-Release number of selected component (if applicable):
gnome-vfs2-smb-2.5.7-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql gnome-vfs2-smb
2. rpm -qf /etc/gnome-vfs-2.0/modules/smb-module.conf
    

Actual Results:  1:
/etc/gnome-vfs-2.0/modules/ssl-modules.conf
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
2:
gnome-vfs2-2.5.7-1


Expected Results:  1:
/etc/gnome-vfs-2.0/modules/smb-module.conf
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
2:
gnome-vfs2-smb-2.5.7-1


Additional info:

triage->easyfix
Comment 1 Alexander Larsson 2004-02-23 11:20:26 EST
Fixed in 2.5.8-1
Comment 2 Gary Peck 2004-02-24 14:54:24 EST
not quite :) gnome-vfs2 still includes
/usr/lib/gnome-vfs-2.0/modules/libsmb.la. it also includes
/etc/gconf/schemas/system_smb.schemas, which should probably be in
gnome-vfs2-smb, though it could conceivably be in the main package too.

also, i just noticed that the files in /usr/lib/gnome-vfs-2.0/modules/
are owned by both gnome-vfs2 and gnome-vfs2-devel.
Comment 3 Alexander Larsson 2004-02-25 03:51:40 EST
The .la files should just die.
The schemas file should be in the main package, because other things
might use that setting.

Should be fixed in gnome-vfs2 2.5.8-2

Note You need to log in before you can comment on or make changes to this bug.