Bug 1158086 - remote-viewer: xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.
Summary: remote-viewer: xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1179477
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-28 14:22 UTC by Evgheni Dereveanchin
Modified: 2019-10-10 09:27 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-2.0-2.el6
Doc Type: Bug Fix
Doc Text:
Using remote-viewer with SSH and the Xming display server caused remote-viewer to terminate unexpectedly. With this update, an assertion no longer triggers in the described circumstances, which prevents the crash from occurring.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:31:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description Evgheni Dereveanchin 2014-10-28 14:22:35 UTC
Description of problem:
After upgrading to RHEV 6.6, it is impossible to use virt-viewer over SSH + Xming combination to view SPICE consoles of VMs.

Version-Release number of selected component (if applicable):
RHEL 6.6
Windows 7
PuTTY 0.63
Xming 6.9.0.31
virt-viewer-0.6.0-11.el6.x86_64
virt-viewer-0.5.6-8.el6_5.3.x86_64

How reproducible:
always

Steps to Reproduce:
1. on a Windows machine, start Xming
2. connect to a RHEL 6.6 machine using PuTTY
3. open firefox, try to open a SPICE console

Actual results:
virt-viewer window opens and closes right away

Expected results:
virt-viewer remains open and displays hte VM console

Additional info:
if running the XPI in debug mode or invoking virt-viewer manually to open a .vv file, this is displayed:

[xcb] Extra reply data still left in queue
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
remote-viewer: xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.
Aborted

The same setup worked with RHEL 6.5 without issues

Comment 4 Pavel Grunt 2015-03-04 07:02:22 UTC
Hi Evgheni, is it still happening ? I don't think the problem is in virt-viewer.

I cannot reproduce it with:
Windows 7 as the client
RHEL 6.6 as the guest
Xming 6.9.0.31
virt-viewer-0.6.0-11.el6.x86_64
spice-gtk-0.22-7.el6.x86_64

Comment 5 Evgheni Dereveanchin 2015-03-06 13:40:42 UTC
Sorry, I cannot keep reproducers for that long. Cannot confirm if it's still there at the moment but half a year ago I was able to reproduce it from the first try. This is probably related to bz#1158613

Comment 6 Evgheni Dereveanchin 2015-03-06 14:02:44 UTC
Just re-tested it. remote-viewer still crashes:

[xminguser@test Downloads]$ remote-viewer -v --debug console.vv
(remote-viewer:6368): remote-viewer-DEBUG: Insert window 0 0x23ab800
(remote-viewer:6368): remote-viewer-DEBUG: No configuration file /home/xminguser/.config/virt-viewer/settings
(remote-viewer:6368): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer:6368): remote-viewer-DEBUG: Opening display to console.vv
(remote-viewer:6368): remote-viewer-DEBUG: Guest console.vv has a spice display
Guest console.vv has a spice display
(remote-viewer:6368): remote-viewer-DEBUG: After open connection callback fd=-1
(remote-viewer:6368): remote-viewer-DEBUG: Opening connection to display at console.vv
Opening connection to display at console.vv
(remote-viewer:6368): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer:6368): remote-viewer-DEBUG: app is not in full screen
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x2454ed0 SpiceMainChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: notebook show status 0x23ba000
(remote-viewer:6368): remote-viewer-DEBUG: main channel: opened
(remote-viewer:6368): remote-viewer-DEBUG: notebook show status 0x23ba000
(remote-viewer:6368): remote-viewer-DEBUG: app is not in full screen
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x24f0c20 SpiceRecordChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x25be000 SpicePlaybackChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: new audio channel
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x25ccf10 SpiceCursorChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x25cfb40 SpiceDisplayChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: New spice channel 0x25d0fa0 SpiceInputsChannel 0
(remote-viewer:6368): remote-viewer-DEBUG: new inputs channel

(remote-viewer:6368): Gtk-WARNING **: Attempting to store changes into `/home/xminguser/.local/share/recently-used.xbel', but failed: Failed to create file '/home/xminguser/.local/share/recently-used.xbel.JMTSUX': No such file or directory

(remote-viewer:6368): Gtk-WARNING **: Attempting to set the permissions of `/home/xminguser/.local/share/recently-used.xbel', but failed: No such file or directory
(remote-viewer:6368): remote-viewer-DEBUG: creating spice display (#:0)
[xcb] Extra reply data still left in queue
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
remote-viewer: xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.
Aborted

I get this on every try, so it's 100% reproduceable.
Tell me if you need additional info from these system. Re-assign to the right component if necessary.

Comment 7 Pavel Grunt 2015-03-06 16:03:03 UTC
Thanks Evgheni, I was able to reproduce it, seems that it is fixed upstream. Can you try it with virt-viewer-2.0-2.el6.x86_64 ?

Comment 9 Evgheni Dereveanchin 2015-03-12 09:50:59 UTC
Just tested and can confirm there's no more virt-viewer crash on virt-viewer-2.0-2.el6.x86_64

Comment 10 CongDong 2015-03-13 01:06:06 UTC
Can reproduce this with 
Windows 7
PuTTY 0.63
virt-viewer-0.6.0-11.el6.x86_64

Steps:
1. prepare a spice guest on rhevm
2. connect the rhel6 host on win7 machine with putty
3. open firefox and connect rhevm
4. configure the guest on rhevm with "Broswer pluing", and try to open the console

Result:
virt-viewer window opens and closes right away
# cat /var/log/message
Mar 13 08:55:21 dc spice: [xcb] Extra reply data still left in queue
Mar 13 08:55:21 dc spice: [xcb] This is most likely caused by a broken X extension library
Mar 13 08:55:21 dc spice: [xcb] Aborting, sorry about that.
Mar 13 08:55:21 dc spice: remote-viewer: xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.

Verify with virt-viewer-2.0-2.el6.x86_64

Result:
virt-viewer can connect the guest successfully, and no error message for spice.

As the result, move to VERIFIED

Comment 13 errata-xmlrpc 2015-07-22 06:31:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.