Bug 115810 - Installer crashes after inputting root password and it starts to read the packages
Installer crashes after inputting root password and it starts to read the pac...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 06:30 EST by Ben Packard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The result of the unhandled exception generated by Anaconda in Fedora Core 2 test 1 (48.43 KB, text/plain)
2004-02-16 06:30 EST, Ben Packard
no flags Details

  None (edit)
Description Ben Packard 2004-02-16 06:30:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.23  [en]

Description of problem:
After looking at the log file I saved from my Testbox, it looks like 
when it gets to the step where, right after inputting the root 
password, it starts to build a list of all components.  It works for 
a minute, then crashes, generating the log file I have attached.

Basically every step of the way during installation, whenever it 
would try to read HDB (A Maxtor 30 GB 5400 rpm hard drive containing 
one NTFS partition) it would say "Unable to align partition properly. 
 This probably means that another partioning tool blah blah blah", 
and I always click Cancel.  And for the record, Fedora Core 1 had no 
problems with this hard drive at all.  Finally, after I input the 
root password it would crash right afterwards.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start CD-ROM based setup as usual
2. Always click "Cancel" on the warnings that would appear in regards 
to HDB's improperly aligned drive geometry.
3. Specify my mouse, keyboard language, time zone and all that jazz 
as usual.
4. Do disk partitioning "Automatically" instead of "Manually via Disk 
Druid".
5. It will then tell me "The partition table on device hdb was 
unreadable. To create new partitions it must be initialized, causing 
the loss of ALL data on this drive".  I always click No.
6. At the next step, I check "Remove all partitions on this system", 
making sure to click Yes to allow it.
7. I click through the next hard-drive related steps without changing 
anything.
8. I then specify my IP address and gateway settings manually, seeing 
as DHCP has given me problems in the past.
9. Specify my language and then my timezone (you guys really need to 
make Houston, TX, USA an option and not just Chicago for Central 
timezone, heh)
10. Input the root password, then click Next.  It starts to read 
packages, then crashes.

Expected Results:  Ummm, I dunno, just maybe I should have been able 
to pick the components I want to install and continue on my merry 
way?  :)

Additional info:
Comment 1 Ben Packard 2004-02-16 06:30:59 EST
Created attachment 97699 [details]
The result of the unhandled exception generated by Anaconda in Fedora Core 2 test 1
Comment 2 Bill Nottingham 2004-02-16 15:01:33 EST
Did you check the CDs with mediacheck?
Comment 3 Jeremy Katz 2004-02-16 23:34:36 EST
Can you verify your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 4 Need Real Name 2004-02-21 19:43:34 EST
 I get the following message after I click on the "next" of the  LCD
resolution section (before type of install: workstation, server, ...)

"Unable to align partition properly.  This means another partitioning
tool generated an incorrect partition table, because it didn't have
the correct BIOS geometry. It is safe to ignore, but ignoring may
cause (fixable) problems with some boot loaders."
-------

There is a bug... or so I think.  I tried this both with the #1 Hard
Drive install (linux askmethod) and #2 CD install, both bring up the
same error.

I have no problems installing FC1 on this exact same partition. (I
have just tried it now)

There is another bug here, in that the two options "Cancel" and
"Ignore" do the exact same thing... continue on to the type on fedora
install (server, workstation, desktop...)  I would expect "Cancel" to
exit and reboot the computer.


--------

I used partition magic, which does not report any errors what so ever
with the partitions. (duel boot winxp/FC2Test1.  I created this from a
"hard drive" install, from a burned boot cdrom install. (linux
askmethod). 

The first time I installed fedora I ignored this warning, and it
installed ok (it did NOT crash like previous post), but partition
magic really messed up everything, and it was all down hill from
there. (had to delete everything with fdisk (dos) before partition
magic (dos) would even format the disk with out freaking out.

I gave it a try again after I reinstalled WinXP, and am still getting
the same error, but I don't want to go through this again.

Any advice

Dell inspiron 8000
HITACHI_DK23CA-30 (30GB)

/dev/hda1  ntfs  14,300 MB
*-------
/dev/hd?1 vfat   4,000 MB
/dev/hd?2 ext3 boot   55 MB
/dev/hd?3 ext3 swap   255 MB
/dev/hd?4 ext3 root   5,740 MB
/dev/hd?5 ext3 home   4,260 MB


MD5SUM is OK when I tested it for the iso. I will test with media
check, but if HD install does not work, I am sure the CD will be the same.

Note You need to log in before you can comment on or make changes to this bug.