Bug 1158173 - pulp-celery has a long, redundant require statement
Summary: pulp-celery has a long, redundant require statement
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: Master
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-28 19:12 UTC by Brian Bouterse
Modified: 2015-02-28 22:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:41:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 595 None None None Never

Description Brian Bouterse 2014-10-28 19:12:49 UTC
The pulp-celery policy has a lot of unnecessary statements in the require section [0]. These should be removed and tested on the platforms.

I believe only pulp_cert_t and puppet_etc_t are required. Even those may not be required with gen_tunable statements.


[0]:  https://github.com/pulp/pulp/blob/553edf38c1e1cd5a3e99bfdcae810c3e9ef39137/server/selinux/server/pulp-celery.te#L8

Comment 1 Brian Bouterse 2015-02-28 22:41:42 UTC
Moved to https://pulp.plan.io/issues/595


Note You need to log in before you can comment on or make changes to this bug.