Bug 115831 - Unable to edit 'long' category names and URLs
Unable to edit 'long' category names and URLs
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Daniel Berrange
http://youth.aplaws.org.uk/ccm/conten...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 11:06 EST by Alan McCann
Modified: 2007-04-18 13:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 10:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan McCann 2004-02-16 11:06:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When using content > Categories > Edit Category to alter a mistyped 
Name, it is impossible to add a character until several characters 
have been deleted.

This occurs when the existing category name is quite long. It seems 
there is a maximum character value for this field, but when the Local 
Government Directories List categories were imported they overrode 
this.

In this example

Local Government Categories List > Social services > Childre, young 
people and families

.... I needed to add an "n" to the word children. I couldn't. I 
deleted a character, but still could add one. In fact, in order to 
add a character I must delete 5.

This seems to be the case in all of a slection of 'long' Category 
names I tried, and also applies to the URL field.

It effectively means these category names cannot be edited in the 
orthodox way.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above.
    

Additional info:
Comment 1 Daniel Berrange 2004-02-16 11:14:32 EST
The CMS UI is imposing an arbitrary limit on the data field which is
much less than what the database is actually capable of storing.
Comment 2 Vadim Nasardinov 2004-02-16 11:23:01 EST
Out of curiousity, what's the formula for translating the maximum
capacity of the underlying DB column into the correct "max" attribute on
the HTML text field?
Comment 3 Scott Seago 2004-02-16 17:50:01 EST
fixed @40451. 
Category editing UI was arbitrarily limiting category name input to 30
characters.

Note You need to log in before you can comment on or make changes to this bug.