Bug 1158396 - firstboot: after registration is complete if you click on back button,it takes you nowhere
Summary: firstboot: after registration is complete if you click on back button,it take...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Keywords:
: 1159936 (view as bug list)
Depends On:
Blocks: rhsm-rhel72
TreeView+ depends on / blocked
 
Reported: 2014-10-29 10:02 UTC by Shwetha Kallesh
Modified: 2015-07-16 12:20 UTC (History)
9 users (show)

(edit)
The "Back" button used in the "firstboot" utility is not working properly. It is often disabled, and if it is enabled, pressing it has no effect. Consequently, during Subscription Management Registration, clicking "Back" does not return you to the previous panel. If you want to go back, enter an invalid server or invalid credentials and click "Done". After this, either an "Unable to reach the server" dialog or an "Unable to register the system" dialog appears at the top of the initial "firstboot" panel. Dismiss the error dialog, and choose the "No, I prefer to register at a later time" option.
Clone Of:
(edit)
Last Closed: 2015-07-16 12:20:48 UTC


Attachments (Terms of Use)
Back button upon pressing takes you nowhere (159.37 KB, image/png)
2014-10-29 10:02 UTC, Shwetha Kallesh
no flags Details
Back button don't work in firstboot of Subscription Management Registration page (91.72 KB, image/png)
2014-12-03 09:42 UTC, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1153634 None None None Never
Red Hat Bugzilla 1191237 None None None Never

Internal Trackers: 1153634 1191237

Description Shwetha Kallesh 2014-10-29 10:02:32 UTC
Created attachment 951702 [details]
Back button upon pressing takes you nowhere

Description of problem:

firstboot: after registration is complete if you click on back button,it takes you nowhere

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.26.3-1
subscription management rules: 5.11
subscription-manager: 1.13.5-1.el7
python-rhsm: 1.13.5-1.el7
subscription-manager-firstboot-1.13.5-1.el7.x86_64

How reproducible:


Steps to Reproduce:
1.firstboot -r
2.register with manually attach check box checked
3.after registration is successful click on back button

Actual results:
takes you nowhere

Expected results:
should take you first page 

Additional info:

Comment 2 Devan Goodwin 2014-11-04 19:57:27 UTC
I am trying to close just about all firstboot bugs, but in this case I kind of think something needs to be done. 

I believe what we're seeing here is the result of us being the only remaining firstboot module. Because there's no other module to go back to, it does nothing. 

Ideally it should just let you "re-start" our module. I'm worried this is a firstboot problem itself, which is unmaintained now, but we should investigate and see if there's anything we can do.

Comment 3 Devan Goodwin 2014-11-04 19:57:53 UTC
*** Bug 1159936 has been marked as a duplicate of this bug. ***

Comment 4 Adrian Likins 2014-11-04 22:56:43 UTC
Hide the back button when we are done?

Comment 5 Lijun Li 2014-12-03 09:39:41 UTC
In case the typo in user name/password or http address, the 'Back' button still don't work.

Please see the attached screen-shot.

Comment 6 Lijun Li 2014-12-03 09:42:35 UTC
Created attachment 964069 [details]
Back button don't work in firstboot of Subscription Management Registration page

Comment 12 Adrian Likins 2015-07-09 20:09:09 UTC
firstboot module is being replaced with an initial-setup module in 7.2+

Comment 13 Chris "Ceiu" Rog 2015-07-16 12:20:48 UTC
As stated in comment 12, first boot has been replaced; new bugs should be reported against subscription-manager-initial-setup-addon.


Note You need to log in before you can comment on or make changes to this bug.