Bug 1158404 - [abrt] cinnamon: cinnamon-slideshow.py:174:on_monitored_folder_changed:Error: g-io-error-quark: Error when getting information for file '/home/pas/Pictures/.GrizzlyPeak_EN-US8978492139_1366x768.jpg.qT8oXw': No such file or directory (1)
Summary: [abrt] cinnamon: cinnamon-slideshow.py:174:on_monitored_folder_changed:Error:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b8597eea61a67722bd647888a4a...
: 1196461 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-29 10:15 UTC by Paul Sand
Modified: 2015-06-06 06:23 UTC (History)
4 users (show)

Fixed In Version: cjs-2.6.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-05 23:48:23 UTC


Attachments (Terms of Use)
File: backtrace (1.08 KB, text/plain)
2014-10-29 10:15 UTC, Paul Sand
no flags Details
File: environ (922 bytes, text/plain)
2014-10-29 10:15 UTC, Paul Sand
no flags Details

Description Paul Sand 2014-10-29 10:15:33 UTC
Version-Release number of selected component:
cinnamon-2.4.0-0.4.gitea748a2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /usr/lib/cinnamon-slideshow/cinnamon-slideshow.py
executable:     /usr/lib/cinnamon-slideshow/cinnamon-slideshow.py
kernel:         3.17.1-302.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
cinnamon-slideshow.py:174:on_monitored_folder_changed:Error: g-io-error-quark: Error when getting information for file '/home/pas/Pictures/.GrizzlyPeak_EN-US8978492139_1366x768.jpg.qT8oXw': No such file or directory (1)

Traceback (most recent call last):
  File "/usr/lib/cinnamon-slideshow/cinnamon-slideshow.py", line 174, in on_monitored_folder_changed
    file_info = file1.query_info("standard::type,standard::content-type", Gio.FileQueryInfoFlags.NONE, None)
Error: g-io-error-quark: Error when getting information for file '/home/pas/Pictures/.GrizzlyPeak_EN-US8978492139_1366x768.jpg.qT8oXw': No such file or directory (1)

Local variables in innermost frame:
file2: None
file1: <__main__.GLocalFile object at 0x7fa7a319c960 (GLocalFile at 0x7fa78801a220)>
monitor: <__main__.GInotifyDirectoryMonitor object at 0x7fa7a3179960 (GInotifyDirectoryMonitor at 0x2749050)>
self: <__main__.CinnamonSlideshow at /org/Cinnamon/Slideshow at 0x7fa7a317a0d0>
file_path: '/home/pas/Pictures/.GrizzlyPeak_EN-US8978492139_1366x768.jpg.qT8oXw'
event_type: <enum G_FILE_MONITOR_EVENT_CREATED of type GFileMonitorEvent>

Comment 1 Paul Sand 2014-10-29 10:15:35 UTC
Created attachment 951728 [details]
File: backtrace

Comment 2 Paul Sand 2014-10-29 10:15:36 UTC
Created attachment 951729 [details]
File: environ

Comment 3 leigh scott 2014-10-29 10:50:23 UTC
https://github.com/linuxmint/Cinnamon/issues/3622

Comment 4 leigh scott 2015-05-23 23:26:48 UTC
*** Bug 1196461 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-05-29 20:01:12 UTC
cjs-2.6.0-1.fc22, muffin-2.6.0-1.fc22, cinnamon-menus-2.6.0-1.fc22, cinnamon-control-center-2.6.0-2.fc22, cinnamon-translations-2.6.1-1.fc22, cinnamon-settings-daemon-2.6.1-1.fc22, cinnamon-session-2.6.1-1.fc22, cinnamon-screensaver-2.6.1-1.fc22, nemo-2.6.5-1.fc22, cinnamon-desktop-2.6.3-2.fc22, cinnamon-2.6.4-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8628/nemo-2.6.5-1.fc22,muffin-2.6.0-1.fc22,cjs-2.6.0-1.fc22,cinnamon-translations-2.6.1-1.fc22,cinnamon-settings-daemon-2.6.1-1.fc22,cinnamon-session-2.6.1-1.fc22,cinnamon-screensaver-2.6.1-1.fc22,cinnamon-menus-2.6.0-1.fc22,cinnamon-desktop-2.6.3-2.fc22,cinnamon-control-center-2.6.0-2.fc22,cinnamon-2.6.4-1.fc22

Comment 6 Fedora Update System 2015-05-29 20:03:45 UTC
muffin-2.6.0-1.fc20, cjs-2.6.0-1.fc20, cinnamon-translations-2.6.1-1.fc20, cinnamon-menus-2.6.0-1.fc20, cinnamon-control-center-2.6.0-2.fc20, cinnamon-settings-daemon-2.6.1-1.fc20, cinnamon-session-2.6.1-1.fc20, cinnamon-screensaver-2.6.1-1.fc20, nemo-2.6.5-1.fc20, cinnamon-desktop-2.6.3-2.fc20, cinnamon-2.6.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2015-8666/nemo-2.6.5-1.fc20,muffin-2.6.0-1.fc20,cjs-2.6.0-1.fc20,cinnamon-translations-2.6.1-1.fc20,cinnamon-settings-daemon-2.6.1-1.fc20,cinnamon-session-2.6.1-1.fc20,cinnamon-screensaver-2.6.1-1.fc20,cinnamon-menus-2.6.0-1.fc20,cinnamon-desktop-2.6.3-2.fc20,cinnamon-control-center-2.6.0-2.fc20,cinnamon-2.6.4-1.fc20

Comment 7 Fedora Update System 2015-05-29 20:04:30 UTC
muffin-2.6.0-1.fc21, cjs-2.6.0-1.fc21, cinnamon-menus-2.6.0-1.fc21, cinnamon-control-center-2.6.0-2.fc21, cinnamon-translations-2.6.1-1.fc21, cinnamon-settings-daemon-2.6.1-1.fc21, cinnamon-screensaver-2.6.1-1.fc21, nemo-2.6.5-1.fc21, cinnamon-session-2.6.1-1.fc21, cinnamon-desktop-2.6.3-2.fc21, cinnamon-2.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-8650/nemo-2.6.5-1.fc21,muffin-2.6.0-1.fc21,cjs-2.6.0-1.fc21,cinnamon-translations-2.6.1-1.fc21,cinnamon-settings-daemon-2.6.1-1.fc21,cinnamon-session-2.6.1-1.fc21,cinnamon-screensaver-2.6.1-1.fc21,cinnamon-menus-2.6.0-1.fc21,cinnamon-desktop-2.6.3-2.fc21,cinnamon-control-center-2.6.0-2.fc21,cinnamon-2.6.4-1.fc21

Comment 8 Fedora Update System 2015-06-01 17:03:29 UTC
Package cjs-2.6.0-1.fc21, cinnamon-menus-2.6.0-1.fc21, cinnamon-control-center-2.6.0-2.fc21, cinnamon-translations-2.6.1-1.fc21, cinnamon-settings-daemon-2.6.1-1.fc21, cinnamon-screensaver-2.6.1-1.fc21, nemo-2.6.5-1.fc21, cinnamon-session-2.6.1-1.fc21, muffin-2.6.1-1.fc21, cinnamon-desktop-2.6.4-2.fc21, cinnamon-2.6.6-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cjs-2.6.0-1.fc21 cinnamon-menus-2.6.0-1.fc21 cinnamon-control-center-2.6.0-2.fc21 cinnamon-translations-2.6.1-1.fc21 cinnamon-settings-daemon-2.6.1-1.fc21 cinnamon-screensaver-2.6.1-1.fc21 nemo-2.6.5-1.fc21 cinnamon-session-2.6.1-1.fc21 muffin-2.6.1-1.fc21 cinnamon-desktop-2.6.4-2.fc21 cinnamon-2.6.6-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8650/nemo-2.6.5-1.fc21,muffin-2.6.0-1.fc21,cjs-2.6.0-1.fc21,cinnamon-translations-2.6.1-1.fc21,cinnamon-settings-daemon-2.6.1-1.fc21,cinnamon-session-2.6.1-1.fc21,cinnamon-screensaver-2.6.1-1.fc21,cinnamon-menus-2.6.0-1.fc21,cinnamon-desktop-2.6.3-2.fc21,cinnamon-control-center-2.6.0-2.fc21,cinnamon-2.6.4-1.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-06-05 23:48:23 UTC
cjs-2.6.0-1.fc21, cinnamon-menus-2.6.0-1.fc21, cinnamon-control-center-2.6.0-2.fc21, cinnamon-translations-2.6.1-1.fc21, cinnamon-settings-daemon-2.6.1-1.fc21, cinnamon-screensaver-2.6.1-1.fc21, nemo-2.6.5-1.fc21, cinnamon-session-2.6.1-1.fc21, muffin-2.6.1-1.fc21, cinnamon-desktop-2.6.4-2.fc21, cinnamon-2.6.6-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-06-05 23:56:10 UTC
cjs-2.6.0-1.fc22, cinnamon-menus-2.6.0-1.fc22, cinnamon-control-center-2.6.0-2.fc22, cinnamon-translations-2.6.1-1.fc22, cinnamon-settings-daemon-2.6.1-1.fc22, cinnamon-session-2.6.1-1.fc22, cinnamon-screensaver-2.6.1-1.fc22, cinnamon-desktop-2.6.4-2.fc22, cinnamon-2.6.6-1.fc22, nemo-2.6.5-1.fc22, muffin-2.6.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-06-06 00:07:59 UTC
cjs-2.6.0-1.fc20, cinnamon-translations-2.6.1-1.fc20, cinnamon-menus-2.6.0-1.fc20, cinnamon-control-center-2.6.0-2.fc20, cinnamon-settings-daemon-2.6.1-1.fc20, cinnamon-session-2.6.1-1.fc20, cinnamon-screensaver-2.6.1-1.fc20, nemo-2.6.5-1.fc20, muffin-2.6.1-1.fc20, cinnamon-desktop-2.6.4-2.fc20, cinnamon-2.6.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.