Bug 1158441
| Summary: | virt-who can't work in the VDSM mode | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | Jan Kurik <jkurik> |
| Component: | virt-who | Assignee: | Radek Novacek <rnovacek> |
| Status: | CLOSED ERRATA | QA Contact: | Li Bin Liu <liliu> |
| Severity: | urgent | Docs Contact: | |
| Priority: | urgent | ||
| Version: | 7.0 | CC: | fdeutsch, gxing, jherrman, ldai, liliu, ovasik, pm-eus, rnovacek, sgao, shihliu |
| Target Milestone: | rc | Keywords: | TestBlocker, ZStream |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | virt-who-0.8-15.el7_0 | Doc Type: | Bug Fix |
| Doc Text: |
Prior to this update, the virt-who agent failed to read the list of virtual guests provided by the VDSM daemon. As a consequence, when in VDSM mode, virt-who was not able to send updates about virtual guests to the Subscription Asset Manager (SAM) and Red Hat Satellite. With this update, virt-who reads the list of guests when in VDSM mode correctly, and reports to SAM and Satellite as expected.
|
Story Points: | --- |
| Clone Of: | 1153405 | Environment: | |
| Last Closed: | 2014-11-12 09:20:42 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1153405 | ||
| Bug Blocks: | |||
|
Description
Jan Kurik
2014-10-29 11:48:02 UTC
Fixed in virt-who-0.8-13.el7_0. It can't be verify as there is a problem block us to do it now, please see the detail reason in bug 1153405 comment 11. Add rhel7.0 to rhevm3.3, then update virt-who-0.8-12.el7 to virt-who-0.8-13.el7_0.noarch. It also reproduced on virt-who-0.8-13.el7_0.noarch, Therefore, reopen it.
Version-Release number of selected component (if applicable):
subscription-manager-1.10.14-8.el7_0.x86_64
python-rhsm-1.10.12-2.el7.x86_64
virt-who-0.8-13.el7_0.noarch
vdsm-4.13.2-4.el7.x86_64
rhevm-3.3.3-0.51.el6ev.noarch
Reproduced steps:
1. Add rhel7.0 to rhevm3.3, then update virt-who-0.8-12.el7 to virt-who-0.8-13.el7_0.noarch.
2. Register rhel7.0 to SAM Server.
3. Configure virt-who run at vdsm mode
# vim /etc/sysconfig/virt-who
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=2
VIRTWHO_VDSM=1
4. Restart virt-who service
# service virt-who restart
5. Check the virt-who log, it will show some error log and host/guest associate hasn't send to SAM server
2014-11-05 15:52:31,756 [DEBUG] @virt-who.py:528 - Virt-who is running in vdsm mode
2014-11-05 15:52:31,757 [DEBUG] @virt-who.py:535 - Starting infinite loop with 2 seconds interval and event handling
2014-11-05 15:53:31,817 [ERROR] @virt-who.py:197 - Error in communication with virt backend, trying to recover:
Traceback (most recent call last):
File "/usr/share/virt-who/virt-who.py", line 189, in _send
virtualGuests = self.virt.listDomains()
File "/usr/share/virt-who/vdsm.py", line 94, in listDomains
response = self.server.list(True)
File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
return self.__send(self.__name, args)
File "/usr/lib64/python2.7/xmlrpclib.py", line 1578, in __request
verbose=self.__verbose
File "/usr/lib64/python2.7/xmlrpclib.py", line 1264, in request
return self.single_request(host, handler, request_body, verbose)
File "/usr/lib64/python2.7/xmlrpclib.py", line 1294, in single_request
response = h.getresponse(buffering=True)
File "/usr/lib64/python2.7/httplib.py", line 1045, in getresponse
response.begin()
File "/usr/lib64/python2.7/httplib.py", line 409, in begin
version, status, reason = self._read_status()
File "/usr/lib64/python2.7/httplib.py", line 365, in _read_status
line = self.fp.readline(_MAXLINE + 1)
File "/usr/lib64/python2.7/socket.py", line 476, in readline
data = self._sock.recv(self._rbufsize)
timeout: timed out
2014-11-05 15:53:31,830 [ERROR] @vdsm.py:88 - 'NoneType' object has no attribute 'group'
Traceback (most recent call last):
File "/usr/share/virt-who/vdsm.py", line 85, in connect
self.server = self._secureConnect()
File "/usr/share/virt-who/vdsm.py", line 65, in _secureConnect
addr = self._getLocalVdsName(self.trust_store_path)
File "/usr/share/virt-who/vdsm.py", line 62, in _getLocalVdsName
return re.search('/CN=([^/]+)/', out).group(1)
AttributeError: 'NoneType' object has no attribute 'group'
There was an error in the regular expression in the patch for this issue. Should be fixed in virt-who-0.8-15.el7_0. After add rhel7.0 to rhevm3.3, update virt-who-0.8-12.el7 to virt-who-0.8-15.el7_0.noarch. it can't reproduce now. therefore, verify it on virt-who-0.8-15.el7_0.noarch. Version-Release number of selected component (if applicable): subscription-manager-1.10.14-8.el7_0.x86_64 python-rhsm-1.10.12-2.el7.x86_64 virt-who-0.8-15.el7_0.noarch vdsm-4.13.2-4.el7.x86_64 rhevm-3.3.3-0.51.el6ev.noarch Verified steps: 1. Add rhel7.0 to rhevm3.3, then update virt-who-0.8-12.el7 to virt-who-0.8-13.el7_0.noarch. 2. Register rhel7.0 to SAM Server. 3. Configure virt-who run at vdsm mode # vim /etc/sysconfig/virt-who VIRTWHO_DEBUG=1 VIRTWHO_INTERVAL=2 VIRTWHO_VDSM=1 4. Restart virt-who service # service virt-who restart 5. Check the virt-who log, virt-who send correct host/guest associate to SAM server 2014-11-07 10:54:21,648 [WARNING] @virt-who.py:515 - Listening for events is not available in VDSM, ESX, RHEV-M or Hyper-V mode 2014-11-07 10:54:21,761 [DEBUG] @virt-who.py:528 - Virt-who is running in vdsm mode 2014-11-07 10:54:21,761 [DEBUG] @virt-who.py:535 - Starting infinite loop with 5 seconds interval and event handling 2014-11-07 10:54:21,812 [DEBUG] @subscriptionmanager.py:104 - Sending list of uuids: ['6e39942d-8065-4518-9c5d-badd9a233e92'] 2014-11-07 10:54:27,398 [DEBUG] @subscriptionmanager.py:104 - Sending list of uuids: ['6e39942d-8065-4518-9c5d-badd9a233e92'] Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2014-1850.html |