Bug 1158607 - bonded interfaces are incorrectly configured with missing bond name
Summary: bonded interfaces are incorrectly configured with missing bond name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-29 17:32 UTC by Jeff Applewhite
Modified: 2015-01-12 18:10 UTC (History)
8 users (show)

Fixed In Version: rhel-osp-installer-0.4.6-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-12 18:10:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Jeff Applewhite 2014-10-29 17:32:34 UTC
Description of problem:

Bonded interface ifcfg- files are malformed

Version-Release number of selected component (if applicable):

foreman-1.6.0.44-6.el6ost.noarch

How reproducible:

Build on a host with multiple interfaces to bond

Steps to Reproduce:
1.Select two interfaces to bond
2.set the mode to 802.3ad
3.drag networks to the bonded interface
4.then do a build.

Actual results:

you will see ifcfg-.300 files in /etc/sysconfig/network-scripts rather than a ifcfg-bond0.300 file as one would expect. the bond0 does not start (DHCP is not available on that VLAN) and the other interfaces fail to start. the config file has the same incorrect device name (as if there is an empty variable for the bond0 name)

Expected results:
a ifcfg-bond0.300 file is create with the proper device in it

Additional info:
this is on a test build for 8.2 beta that NetApp was given

Comment 3 Colin Devine 2014-10-31 14:32:51 UTC
Jeff,

This looks like it will be fixed in the A2 release.

Thanks for reporting this.

--Colin Devine

Comment 4 Alexander Chuzhoy 2014-10-31 17:26:20 UTC
Verified:

rhel-osp-installer-0.4.7-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.13-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.32-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch



Verified that:
1. ifcfg-bond0 configuration file was created under /etc/sysconfig/network-scripts/
2. It has the proper device name in it "DEVICE="bond0""
3. The bond and the other interfaces started.

Comment 6 errata-xmlrpc 2014-11-04 17:04:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html

Comment 7 Jeff Applewhite 2014-11-12 23:03:32 UTC
This bug is still present in the A2 release> I just tested it
my ifcfg files are as follows:

ifcfg-.300
ifcfg-.3002
ifcfg-.500
ifcfg-bond0

with the device contained within them as .300 instead of bond0.300

Comment 8 Jeff Applewhite 2014-11-21 15:24:18 UTC
I found the source of this bug on my deployment in the /tmp/ks-script-oSI4Cn script:


# bond0.300 interface
real=`ip -o link | grep  | awk '{print $2;}' | sed s/:$//`

the above code greps for a blank mac address, and obviously comes up with no interface name - this then propagates down through the interface config file names and devices within them (being blank)

Comment 9 Brad P. Crochet 2014-12-18 13:13:20 UTC
Please try with latest builds

Comment 10 Alexander Chuzhoy 2014-12-29 19:43:57 UTC
Verified:

Environment:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el7ost.noarch
openstack-foreman-installer-3.0.8-1.el7ost.noarch
ruby193-rubygem-staypuft-0.5.9-1.el7ost.noarch
rhel-osp-installer-client-0.5.4-1.el7ost.noarch
openstack-puppet-modules-2014.2.8-1.el7ost.noarch
rhel-osp-installer-0.5.4-1.el7ost.noarch



running "ls /etc/sysconfig/network-scripts/ifcfg*|grep bond" results in:
/etc/sysconfig/network-scripts/ifcfg-bond0
/etc/sysconfig/network-scripts/ifcfg-bond0.300

The DEVICE line looks as following:
DEVICE="bond0.300"


Note You need to log in before you can comment on or make changes to this bug.