Bug 1158617 - Please update python-tornado to > 3.1
Summary: Please update python-tornado to > 3.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-tornado
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Charalampos Stratakis
QA Contact: Jan Kepler
Lenka Špačková
URL:
Whiteboard: FutureFeature
Depends On:
Blocks: 1203710 1298243 1136051 1380359 1393868
TreeView+ depends on / blocked
 
Reported: 2014-10-29 17:53 UTC by Thomas Spura
Modified: 2020-04-15 14:10 UTC (History)
15 users (show)

Fixed In Version: python-tornado-4.2.1-1.el7
Doc Type: Release Note
Doc Text:
_python-tornado_ rebased to version 4.2.1 The _python-tornado_ package has been upgraded to upstream version 4.2.1, which provides a number of bug fixes and new features over the previous version. Notable changes include: * A new `tornado.netutil.Resolver` class, which provides an asynchronous interface to DNS resolution * A new `tornado.tcpclient` module, which creates TCP connections with non-blocking DNS, SSL handshaking, and support for IPv6 * The `IOLoop.instance()` function is now thread-safe * Logging has been improved; low-level logs are less frequent; *Tornado* uses its own logger instead of the root logger, which enables more detailed configuration * Multiple reference cycles have been separated within _python-tornado_, enabling more efficient garbage collection on `CPython` * Coroutines are now faster and are used extensively within *Tornado*.
Clone Of:
Environment:
Last Closed: 2017-08-01 20:30:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1913 normal SHIPPED_LIVE python-tornado bug fix and enhancement update 2017-08-01 18:26:09 UTC

Description Thomas Spura 2014-10-29 17:53:09 UTC
Description of problem:
We like to add ipython to epel7, which requires a more recent version of python-tornado.

Please reconsider to update python-tornado in the next RHEL release to a more recent version.

Until then, we'll probably provide new versions in a COPR repository:
https://copr.fedoraproject.org/coprs/tomspur/ipython/

Comment 3 Orion Poplawski 2015-02-25 21:01:59 UTC
As near as I can tell, python-tornado is only in EL7 currently to provide a BR for python-urllib3 for unit testing.

Comment 4 Louis Abel 2016-01-05 02:08:42 UTC
Hello.

Is there any movement on this? There are some packages/dependencies out there that require a python-tornado version of 4.2.1 or higher (example, saltstack cannot be rebased to 2015.8 in EPEL because it requires python-tornado of 4.2.1 or higher). 

Saltstack example: https://bugzilla.redhat.com/show_bug.cgi?id=1281995

Tickets that reference python-tornado and rebasing.
https://bugzilla.redhat.com/show_bug.cgi?id=1272810
https://bugzilla.redhat.com/show_bug.cgi?id=1295484

Comment 5 Tomas Orsava 2016-10-11 15:07:12 UTC
A little update: ipython already is in epel7 and it works. python-tornado >= 4.0 is only needed for the optional subpackage `python-ipython-notebook`.

Comment 13 errata-xmlrpc 2017-08-01 20:30:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1913


Note You need to log in before you can comment on or make changes to this bug.