Bug 115863 - rpmbuild -bb freetype.spec fails at find-lang.sh
rpmbuild -bb freetype.spec fails at find-lang.sh
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 13:35 EST by Alexander Kain
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 12:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kain 2004-02-16 13:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
rpmbuild -bb freetype.spec fails at find-lang.sh



Version-Release number of selected component (if applicable):
2.1.7-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh freetype-2.1.7-1.src.rpm
2. rpmbuild -bb freetype.spec
3.
    

Actual Results:  ...
+ popd
/usr/src/redhat/BUILD/freetype-2.1.7
+ mkdir -p /var/tmp/freetype-2.1.7-root//usr/include/freetype1
+ mv /var/tmp/freetype-2.1.7-root//usr/include/freetype
/var/tmp/freetype-2.1.7-root//usr/include/freetype1
+ libtool install -m 755 ft2demos-2.1.7/bin/ftdump
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftdump
/var/tmp/freetype-2.1.7-root//usr/bin/ftdump
+ libtool install -m 755 ft2demos-2.1.7/bin/ftlint
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftlint
/var/tmp/freetype-2.1.7-root//usr/bin/ftlint
+ libtool install -m 755 ft2demos-2.1.7/bin/ftmemchk
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftmemchk
/var/tmp/freetype-2.1.7-root//usr/bin/ftmemchk
+ libtool install -m 755 ft2demos-2.1.7/bin/ftmulti
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftmulti
/var/tmp/freetype-2.1.7-root//usr/bin/ftmulti
+ libtool install -m 755 ft2demos-2.1.7/bin/ftstring
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftstring
/var/tmp/freetype-2.1.7-root//usr/bin/ftstring
+ libtool install -m 755 ft2demos-2.1.7/bin/fttimer
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/fttimer
/var/tmp/freetype-2.1.7-root//usr/bin/fttimer
+ libtool install -m 755 ft2demos-2.1.7/bin/ftview
/var/tmp/freetype-2.1.7-root//usr/bin
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
install -m 755 ft2demos-2.1.7/bin/.libs/ftview
/var/tmp/freetype-2.1.7-root//usr/bin/ftview
+ /usr/lib/rpm/find-lang.sh /var/tmp/freetype-2.1.7-root freetype
No translations found for freetype in /var/tmp/freetype-2.1.7-root
error: Bad exit status from /var/tmp/rpm-tmp.56477 (%install)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.56477 (%install)


Expected Results:  success

Additional info:

XFree86-devel is installed. zlib-devel is installed. Changed .spec
file in one location: 

%define without_bytecode_interpreter    0
                                                                     
          
This is the reason why I'd like to recompile freetype.
Comment 1 Alexander Kain 2004-04-30 00:45:52 EDT
Also, xorg-x11-devel is a dependency which is not checked against in
the check file, instead it just bombs when it tries to include
/usr/X11/include
Comment 2 Alexander Kain 2004-05-21 12:14:03 EDT
This is fixed in the release version of FC2

Note You need to log in before you can comment on or make changes to this bug.