Bug 11587 - lilocheck does not work
lilocheck does not work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-22 17:04 EDT by Sean Utt
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 17:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diff for RedHat/instimage/usr/lib/anaconda/kickstart.py to fix the lilocheck option (488 bytes, patch)
2000-06-07 20:39 EDT, Sean Utt
no flags Details | Diff

  None (edit)
Description Sean Utt 2000-05-22 17:04:56 EDT
Hi,

First off, it would be nice if there was a way to dump the errors from an
install to a floppy disk on failure. Writing down the error and carrying it
across the room to type it back in is a rather primitive method of doing
things.

lilocheck is failing with the following error:

File: "/usr/lib/anaconda/kickstart.py", line 84, in doLiloCheck drives =
isys.hardDriveList ().keys() AttributeError: hardDriveList

I am going to guess that someone typo'd here, since this is what I see when
I cd to the anaconda dir on my updated (patched) cd directory and

grep -i harddrive * */* 2>/dev/null
fstab.py:       drives = isys.hardDriveDict().keys()
fstab.py:       return isys.hardDriveDict()
isys.py:def hardDriveDict():
kickstart.py:        drives = isys.hardDriveList ().keys()
kickstart.py:                "harddrive"        : None                  ,
raidstart-stub:drives = isys.hardDriveDict().keys()
todo.py:        d = isys.hardDriveDict()

All the other routines use sys.hardDriveDict().

I modified the kickstart.py to test this theory.

I changed drives = isys.hardDriveList ().keys() to
drives = isys.hardDriveDict().keys()

After making that change, the kickstart reboots the system without any
message as to why. I am guessing that is what it was supposed to do, but a
message of some kind, like: "LiloCheck: Lilo detected in boot sector,
probable existing install, kickstart aborting." would be helpful.

On a slightly more advanced note:

Is it possible for the kickstart to simply boot off the hard drive at that
point, instead of rebooting? The reason I am asking is that I have built
custom CD's that contain a ks.cfg in the initrd.img in the etc directory,
and the default in the syslinux.cfg is to boot the kickstart. If the
lilocheck routine could switch the boot to the hard drive, the CD could be
left in the drive after the install without having to switch the boot
device, and the installed rpm's could be verified against the files on the
CD.


Thanks,
Sean Utt
sean@northwest.com
Comment 1 Sean Utt 2000-06-07 20:39:26 EDT
Created attachment 338 [details]
diff for RedHat/instimage/usr/lib/anaconda/kickstart.py to fix the lilocheck option
Comment 2 Michael Fulbright 2000-06-16 11:28:13 EDT
We're hoping to have time to add a facility to write the traceback to a
floppy.

I will look into your other issues.
Comment 3 Michael Fulbright 2000-06-22 14:10:43 EDT
Could you attach the kickstart file which caused the problem, as well as
a description of how to reproduce it?
Comment 4 Michael Fulbright 2000-08-17 17:38:11 EDT
Please reopen this report if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.