Bug 1158793 - mem-path option cause qemu-kvm-rhev core dump
Summary: mem-path option cause qemu-kvm-rhev core dump
Keywords:
Status: CLOSED DUPLICATE of bug 1147354
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Luiz Capitulino
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-30 09:06 UTC by FuXiangChun
Modified: 2014-10-30 14:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-30 14:27:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description FuXiangChun 2014-10-30 09:06:36 UTC
Description of problem:
If mem-path="no exist file", qemu-kvm-rhev will core dump. 


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -m 1G  -object memory-backend-file,host-nodes=0,id=mem-0,policy=bind,prealloc=yes,mem-path=/mnt/kvm_hugepage0,size=1G -numa node,nodeid=0,memdev=mem-0

2.
3.

Actual results:
/mnt/kvm_hugepage0: No such file or directory
Bad ram offset fffffffffffff000
Aborted (core dumped)

(gdb) bt
#0  0x00007ffff1a075e9 in raise () from /lib64/libc.so.6
#1  0x00007ffff1a08cf8 in abort () from /lib64/libc.so.6
#2  0x0000555555622d0a in qemu_get_ram_block (addr=<optimized out>) at /usr/src/debug/qemu-2.1.2/exec.c:797
#3  0x0000555555624f59 in qemu_get_ram_ptr (addr=18446744073709547520) at /usr/src/debug/qemu-2.1.2/exec.c:1512
#4  0x0000555555658b27 in memory_region_get_ram_ptr (mr=mr@entry=0x555556190940)
    at /usr/src/debug/qemu-2.1.2/memory.c:1458
#5  0x0000555555761e1c in host_memory_backend_memory_complete (uc=<optimized out>, errp=0x7fffffffe090)
    at backends/hostmem.c:291
#6  0x00005555557357b5 in object_add (type=<optimized out>, id=0x55555618eb80 "mem-0", 
    qdict=qdict@entry=0x55555618f410, v=0x55555618f310, errp=errp@entry=0x7fffffffe0e8) at qmp.c:630
#7  0x00005555557237a4 in object_create (opts=<optimized out>, opaque=<optimized out>) at vl.c:2899
#8  0x000055555588fd6b in qemu_opts_foreach (list=<optimized out>, 
    func=func@entry=0x555555723600 <object_create>, opaque=opaque@entry=0x0, 
    abort_on_failure=abort_on_failure@entry=0) at util/qemu-option.c:1072
#9  0x000055555561cecc in main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4240

Expected results:
qemu-kvm-rhev provide a correctly error message. 
e.g 
/mnt/kvm_hugepage0: No such file or directory

Additional info:

Comment 2 Luiz Capitulino 2014-10-30 14:27:40 UTC

*** This bug has been marked as a duplicate of bug 1147354 ***


Note You need to log in before you can comment on or make changes to this bug.