Bug 11588 - RH6.2 krb5 errata breaks credential forwarding over rsh
RH6.2 krb5 errata breaks credential forwarding over rsh
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 17404 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-22 17:39 EDT by Stephen Tweedie
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-11 14:28:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2000-05-22 17:39:56 EDT
The krb5-1.1.1-16 errata upgrade breaks "rsh -f"'s credential
forwarding.  The fault is on the server side: an upgraded client
(also running the upgraded KDC) can still correctly connect to
an unupgraded host via rsh -f, with ticket forwarding working OK.

Forwarding in general still works: telnet -f succeeds.  Only
the kerberised rsh (with or without "-x" session encryption)
fails.

This is rather high priority, as single-signon is the whole
point of kerberos, and that functionality breaks over more than
one hop in the upgraded packages.
Comment 1 Nalin Dahyabhai 2000-06-10 17:27:35 EDT
Fixed in rsh, still hunting for it in rlogin.
Comment 2 Nalin Dahyabhai 2000-09-11 14:28:55 EDT
*** Bug 17404 has been marked as a duplicate of this bug. ***
Comment 3 Nalin Dahyabhai 2000-09-12 14:29:38 EDT
This should be fixed in krb5-1.1.1-25 and krb5-1.2.1-9 and later.  Until Raw
Hide gets refreshed, new packages can be grabbed from
http://people.redhat.com/nalin/krb5/.

Note You need to log in before you can comment on or make changes to this bug.