Bug 1158842 - json-c pkgconfig files installed in the wrong place
Summary: json-c pkgconfig files installed in the wrong place
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: json-c
Version: 6.6
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Filak
QA Contact: Ondřej Pták
URL:
Whiteboard:
: 1193792 (view as bug list)
Depends On:
Blocks: 1152222
TreeView+ depends on / blocked
 
Reported: 2014-10-30 11:16 UTC by Alejandro Alvarez
Modified: 2016-12-01 00:47 UTC (History)
7 users (show)

Fixed In Version: json-c-0.11-12.el6
Doc Type: Bug Fix
Doc Text:
The pkg-config (.pc) files for JSON-C were incorrectly placed in the /lib64/pkgconfig/ directory in the 64-bit packages and in the /lib/pkgconfig/ directory in the 32-bit packages. Consequently, the pkg-config tool was unable to find these files and failed to provide the location of the installed JSON-C libraries, header files, and other information about JSON-C. With this update, the pkg-config files have been moved to the /usr/lib64/pkgconfig/ and /usr/lib/pkgconfig/ directory respectively. As a result, the pkg-config tool now successfully returns information about the installed JSON-C packages.
Clone Of:
: 1199995 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:29:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1397 normal SHIPPED_LIVE json-c bug fix update 2015-07-20 18:07:26 UTC
Red Hat Bugzilla 1134001 None None None 2019-06-12 13:53:32 UTC

Internal Links: 1134001

Description Alejandro Alvarez 2014-10-30 11:16:03 UTC
Description of problem:

pkgconfig files land in /lib64/pkgconfig instead of /usr/lib64/pkgconfig

# rpm -ql json-c-devel-0.11-11.el6.x86_64
/lib64/libjson-c.so
/lib64/libjson.so
/lib64/pkgconfig/json-c.pc
/lib64/pkgconfig/json.pc
/usr/include/json
/usr/include/json-c
/usr/include/json/arraylist.h
/usr/include/json/bits.h
/usr/include/json/debug.h
/usr/include/json/json.h
/usr/include/json/json_c_version.h
/usr/include/json/json_config.h
/usr/include/json/json_inttypes.h
/usr/include/json/json_object.h
/usr/include/json/json_object_iterator.h
/usr/include/json/json_object_private.h
/usr/include/json/json_tokener.h
/usr/include/json/json_util.h
/usr/include/json/linkhash.h
/usr/include/json/printbuf.h
/usr/include/json/random_seed.h

# ls /lib64/pkgconfig/
json-c.pc  json.pc

Version-Release number of selected component (if applicable):
0.11-11.el6

Comment 2 Alejandro Alvarez 2014-12-11 15:11:14 UTC
Ping?

Comment 3 Tomas Heinrich 2015-01-05 15:31:47 UTC
Sorry for the wait.

You're right that the location is wrong and needs to be fixed.
It'll happen with the next update - can't say when that will be though.

Comment 4 Jakub Filak 2015-02-18 11:38:21 UTC
*** Bug 1193792 has been marked as a duplicate of this bug. ***

Comment 6 Jakub Filak 2015-02-25 15:16:42 UTC
According to FHS /lib is for libraries essential for the binaries in /bin/ and /sbin/, therefore *-devel packages must not install anything to /lib.

Test case from bug #1193792:
# yum install json-c-devel
$ pkg-config --exists json-c && echo "Yes" || echo "No"

Comment 10 Ondřej Pták 2015-04-13 07:56:24 UTC
json-c-devel-0.11-11.el6.x86_64
===============================
# rpm -ql json-c-devel | grep \.pc
/lib64/pkgconfig/json-c.pc
/lib64/pkgconfig/json.pc

# pkg-config --libs json-c
Package json-c was not found in the pkg-config search path.
Perhaps you should add the directory containing `json-c.pc'
to the PKG_CONFIG_PATH environment variable
No package 'json-c' found


json-c-devel-0.11-12.el6.x86_64
===============================

# rpm -ql json-c-devel | grep \.pc
/usr/lib64/pkgconfig/json-c.pc
/usr/lib64/pkgconfig/json.pc

# pkg-config --libs json-c
-L/lib64 -ljson-c

Comment 11 errata-xmlrpc 2015-07-22 07:29:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1397.html


Note You need to log in before you can comment on or make changes to this bug.