Bug 1158892 - FailureDetector resource generates configuration history item any time current configuration is accessed in UI
Summary: FailureDetector resource generates configuration history item any time curren...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Configuration
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR02
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Matt Mahoney
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-30 13:10 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:04:49 UTC


Attachments (Terms of Use)

Description Libor Zoubek 2014-10-30 13:10:28 UTC
Description of problem:

It looks like there's small issue with server-side code comparing configurations coming from agent. Under storage node, there's a resource which generates config history items, while it's configuration is not changed.

Version-Release number of selected component (if applicable):
JON 3.3.0.ER05

How reproducible: always


Steps to Reproduce:
1. go to RHQ Storage Node > Network Services > Failure Detector
2. switch several times between Current configuration and Configuration history

Actual results:

history keeps growing, but when you comppare configuration versions, there's no notable change


Expected results: history items should not be created as the configuration has not changed


Additional info:

Comment 1 Jay Shaughnessy 2014-10-31 18:07:39 UTC
This is because the "All Endpoint States" value has a heartbeat counter that reports a different integer on every query for the configuration, making the values different.

This is not a good configuration property, as it's value is changing very frequently.  I'll look to see if it can be stripped from the property value.

** This problem does not affect other resource types as far as I can tell. **

Comment 2 Jay Shaughnessy 2014-10-31 18:13:11 UTC
(2:10:31 PM) jshaughn: jsanda: or stefan_n_lunch or anyone that wrote the cassandra plugin should comment
(2:11:28 PM) jshaughn: The easiest fix would be to kill off that property.  Otherwise we'll have to subclass the component class and take care of that value manually

Comment 3 Stefan Negrea 2014-10-31 19:27:38 UTC
Removed AllEndpointStates property of FailureDetector service from the plugin descriptor. This will prevent a high curn of configuration changes for the service due to the ever changing nature of the property. The property is not needed at this point by any functionality in the Cassandra or Storage Node plugins.


master branch commit:

commit a50762685c10958bf4383f0c31e759916b80ddf6
Author: Stefan Negrea <snegrea@redhat.com>
Date:   Fri Oct 31 14:25:23 2014 -0500

    [BZ 1158892] Remove AllEndpointStates property of FailureDetector service from the plugin descriptor. This will prevent a high

Comment 4 Jay Shaughnessy 2014-11-06 17:19:41 UTC
release/jon3.3.x commit e36808b0dfa607e2d65dc38eeae5ed8eb7b60868
Author: Stefan Negrea <snegrea@redhat.com>
Date:   Fri Oct 31 14:25:23 2014 -0500

    (cherry picked from commit a50762685c10958bf4383f0c31e759916b80ddf6)
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>

Comment 5 Simeon Pinder 2014-11-14 04:48:19 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com//buildinfo?buildID=398756


Note You need to log in before you can comment on or make changes to this bug.