Bug 115905 - modprobe keybdev, mousedev fails early during non-rhgb boot
modprobe keybdev, mousedev fails early during non-rhgb boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-16 18:04 EST by John Reiser
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 12:28:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-02-16 18:04:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Early under non-rhgb boot (remove "rhgb" from the kernel line in
grub.conf), modprobe complains about cannot find keybdev and mousedev.
 The rest of the boot succeeds, and normal operation ensues.

Version-Release number of selected component (if applicable):
initscripts-7.46-1

How reproducible:
Always

Steps to Reproduce:
1. Fresh install Fedora Core 2 test 1 Workstation.
2. Remove "rhgb" from the kernel line in /boot/grub/grub.conf.
3. Boot.
    

Actual Results:  Complaints about keybdev and mousedev missing. 
Complaints go to VGA console, and do not show up in "dmesg" nor in
/var/log/messages.

Expected Results:  No complaints.

Additional info:
Configuration is VGA console, USB wheel mouse, AT Translated Set 2
keyboard on isa0060/serio0.
Comment 1 Sammy 2004-02-16 19:57:14 EST
This happened to me too some time ago. The problem is those modules do not 
exist under Kernel 2.6 and they have to be replaced by usbmouse and usbkbd 
or whatever in rc.sysinit. I have done this and I am not getting any errors. 
HOWEVER, you also need to remove them from modprobe.conf.dist AND 
there is an occurance in some files in /etc/hotplug stuff (search for keyboard). 
After commenting all that stuff I got a perfectly working system. This and the 
/proc/bus/usb stuff that should become /sys/bus/usb in rc.sysinit would result 
in a perfectly smooth system! 
Comment 2 Bill Nottingham 2004-02-17 00:40:54 EST
Actually, you shouldn't need to load anything in rc.sysinit.
Comment 3 Sammy 2004-02-17 10:20:28 EST
I agree. I have all that commented out (the block under the line 
needusbsotorage= 
 
However, the comment sais to get it from hotplug, but last time I 
checked hotplug was also referring to the wrong module. 
Comment 4 Bill Nottingham 2004-02-17 10:57:20 EST
Hotplug may be referring to the wrong module, yes. But rc.sysinit
shouldn't even be trying to load keybdev/mousedev on 2.6 (they are
built in, as they really should be.)
Comment 5 Nils Philippsen 2004-04-21 10:05:39 EDT
No complaints about this here, so I'll close it for now. Please reopen
if you still have issues.

Note You need to log in before you can comment on or make changes to this bug.