Bug 1159061 - [abrt] mate-applets: quotes.py:222:parse_yahoo_csv:IndexError: list index out of range
Summary: [abrt] mate-applets: quotes.py:222:parse_yahoo_csv:IndexError: list index out...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-applets
Version: 21
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0dd5eb1354164e78718d8b9cc7d...
: 1177493 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-30 19:59 UTC by Sviatoslav Semchishin
Modified: 2015-01-15 00:00 UTC (History)
5 users (show)

Fixed In Version: mate-applets-1.8.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-13 00:06:41 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (717 bytes, text/plain)
2014-10-30 19:59 UTC, Sviatoslav Semchishin
no flags Details
File: environ (910 bytes, text/plain)
2014-10-30 19:59 UTC, Sviatoslav Semchishin
no flags Details

Description Sviatoslav Semchishin 2014-10-30 19:59:19 UTC
Version-Release number of selected component:
mate-applets-1.8.1-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        python /usr/libexec/mate-applets/invest-applet
executable:     /usr/libexec/mate-applets/invest-applet
kernel:         3.16.6-200.fc20.i686+PAE
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
quotes.py:222:parse_yahoo_csv:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mate_invest/quotes.py", line 184, in on_currency_retriever_completed
    self.convert_currencies(self.parse_yahoo_csv(csv.reader(retriever.data)))
  File "/usr/lib/python2.7/site-packages/mate_invest/quotes.py", line 222, in parse_yahoo_csv
    result[fields[0]][field] = fields[i]
IndexError: list index out of range

Local variables in innermost frame:
csvreader: <_csv.reader object at 0x8e99a3c>
i: 1
fields: ['RUBUAH=X']
self: <QuoteUpdater object at 0x8e87a54 (mate_invest+quotes+QuoteUpdater at 0x8eaa0a0)>
field: 'label'
result: {'RUBUAH=X': {'ticker': 'RUBUAH=X'}}

Comment 1 Sviatoslav Semchishin 2014-10-30 19:59:22 UTC
Created attachment 952321 [details]
File: backtrace

Comment 2 Sviatoslav Semchishin 2014-10-30 19:59:23 UTC
Created attachment 952322 [details]
File: environ

Comment 3 Wolfgang Ulbrich 2014-12-30 20:24:52 UTC
*** Bug 1177493 has been marked as a duplicate of this bug. ***

Comment 4 Wolfgang Ulbrich 2014-12-30 21:35:05 UTC
upstream wants to know which stock symbols are you using when the issue occours?
Or maybe did the whole pannel crashed during this abrt alert?

Comment 5 Wolfgang Ulbrich 2014-12-30 21:44:12 UTC
I'm not sure but I believe this issue happens when the applet attempts to fetch
when there is a issue with the network, i.e. the contents cannot be retrieved.

Comment 6 Wolfgang Ulbrich 2014-12-31 15:38:12 UTC
https://github.com/mate-desktop/mate-applets/issues/119
I can reproduce the issue when switching to another currency than USD.

Comment 7 Fedora Update System 2015-01-06 00:16:15 UTC
mate-applets-1.8.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-applets-1.8.1-2.fc20

Comment 8 Fedora Update System 2015-01-06 00:16:22 UTC
mate-applets-1.8.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mate-applets-1.8.1-2.fc21

Comment 9 Fedora Update System 2015-01-07 01:25:10 UTC
Package mate-applets-1.8.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-applets-1.8.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0263/mate-applets-1.8.1-2.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-01-13 00:06:41 UTC
mate-applets-1.8.1-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-01-15 00:00:44 UTC
mate-applets-1.8.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.