Bug 115912 - (FLOPPY IRQ?)floppy0: unexpected interrupt // floppy0: sensei repl[0]=80
(FLOPPY IRQ?)floppy0: unexpected interrupt // floppy0: sensei repl[0]=80
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-16 18:40 EST by Luca 'FISH' PERSICO
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca 'FISH' PERSICO 2004-02-16 18:40:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20021003

Description of problem:
Every time after I have mounted, as root user, the floppy device on
/mnt/fd0 I receive the error message in the summary; that error
message is reported on two lines and it is issued after a while that I
start typing something on my keyboard.The characteristics of my Lap
Top PC are:

- PC Brand and Model:
  NEVADA CLEVO 2700S
- Web Sites:
  http://www.nevadaweb.it
  http://www.clevo.com.tw
- BIOS:
  SystemSoft MobilePRO BIOS Version 1.01 (2482-00)-(R1.14)
- Processor:
  Pentium III 900MHz
- RAM:
  256 Mb
- Chipset:
  SiS
- Video Card:
  SiS630 with shared memory (at the present 32Mb video memory)
- DVD:
  Toshiba DVD-ROM SD-C2502
- Hard Disk:
  Hitachi DK23DA-20
- Audio:
  SiS 7018 (AC'97 compatible)
- Controller floppy:
  Standard
- Controller IDE:
  SiS 5513 Dual PCI
- Controller USB:
  SiS 7001
- Mouse:
  PS2
- Ports:
  1 serial
  1 parallel
  1 infrared
  1 PCMCIA CardBus PCI-1410 Texas Instruments
  1 SiS900 10/100 Ethernet
- Modem:
  Incorporated SiS Intel 537 56k Winmodem

Operating System:
Linux Fedora 1.a

Problem:
When I mount as root user a floppy with the command:
mount /dev/fd0
after a while if I use the keyboard I receive repetedly the
following error message:

floppy0: unexpected interrupt
floppy0: sensei repl[0]=80

Why? Is there any method to correct this trouble?

Please would you note that if I use Linux SlackWare 9.1 on the
same PC this problem does not arrive at all, while I had the same
problem with Linux RedHat 9.a

Many thanks and best regards.

Luca 'FISH' PERSICO

Version-Release number of selected component (if applicable):
kernel 2.4.22

How reproducible:
Always

Steps to Reproduce:
1.Insert a floppy in the drive
2.Issue the command: mount /dev/fd0
3.Type something on the keyboard many times.
    

Actual Results:  I received the error message:

floppy0: unexpected interrupt
floppy0: sensei repl[0]=80


Expected Results:  I should not receive any error at all.

Additional info:

See the above descriptions for the lap top computer's configuration I
found the problem with.
Comment 1 Dave Jones 2004-03-21 11:46:20 EST
does this go away if you boot with acpi=on ?
Comment 2 Luca 'FISH' PERSICO 2004-03-27 04:50:21 EST
Dear Mr. JONES,

I tried out the solution of putting the option acpi=on at the end of
the line starting with 'kernel' word in the grub.conf file, but
unluckily I obtained no results and the problem has continued to arise.

Best Regards and many thanks.

Luca 'FISH' PERSICO
Comment 3 Luca 'FISH' PERSICO 2004-05-06 16:48:33 EDT
I tried to find out in Fedora some tool to discover which IRQ the
Floppy is using, but I did not succeed; unluckily, also in my BIOS Setup
Software there is no possibility to have that information, thus I
cannot answer to your question about the Floppy IRQ in my system. I am
very sorry and I apologize.

I still thank you so much again.

Luca 'FISH' PERSICO
Comment 4 Luca 'FISH' PERSICO 2004-06-21 16:27:26 EDT
I come back again on this subject because I did some other trial to
solve it
and I discovered something that maybe, I hope, could be a clue for you
to find
the solution.

Typing the command:
man bootparam
I found in that man page a section dedicated to the floppy drive;
there, they
talk also about an error situation arising with IBM L40SX laptops,
probably
caused by the video card, which brings the error message:
Floppy unexpected interrupt.
They say that till now the problem is unsolved, but to avoid at least the
issueing of the error message by the system it is possible to boot the
machine
giving the kernel the option:
floppy=no_unexpected_interrupt
or the other, equivalent, one:
floppy=L40SX

I tried both of them, and I tried some other option specified in the
man page,
but without any positive result. I hope that you can give me some more
information or, maybe, the solution. I can confirm to you that I have this
problem only with RedHat and Fedora, not with Slackware.

Hoping to have been at least just a little bit useful for you, I thank you
very much for your great job, as usual...

Luca 'FISH' PERSICO
Comment 5 David Lawrence 2004-09-29 16:05:47 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.