Bug 115928 - system monitor applet lies
Summary: system monitor applet lies
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-17 05:03 UTC by Scott Sloan
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-28 06:33:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot on what is going on (41.48 KB, image/png)
2004-02-17 05:04 UTC, Scott Sloan
no flags Details
System Monitor miss reading I think (42.87 KB, image/png)
2004-02-18 06:43 UTC, Scott Sloan
no flags Details

Description Scott Sloan 2004-02-17 05:03:40 UTC
Description of problem:

gnome applet system monitor reports that 100% of the memory is in use
when top shows different. picture is attached. Guessing systm monitor
applet isn't reading from the kernel correctly


Version-Release number of selected component (if applicable):

gnome-applets-2.5.4

How reproducible:

Very likely

Steps to Reproduce:
1. add system monitor to panel
2. tell it to show memory usage
3.
  
Actual results:

Says 100% of memory is full when it's not

Expected results:

to tell the truth

Additional info:

Comment 1 Scott Sloan 2004-02-17 05:04:22 UTC
Created attachment 97726 [details]
Screen shot on what is going on

Comment 2 Scott Sloan 2004-02-18 06:39:36 UTC
Further investigation points to gnome's system monitor is mostly
likely at fault. When I open up system monitor and click on the access
Monitor tab, under memory System monitor is not correctly displaying
both physical (1 GB of DDR) and swap (1024 MB). If the applet is
reading the information from here, the bug lies not within the applet
but within system monitor. Following is a posted screen shot.

Comment 3 Scott Sloan 2004-02-18 06:43:42 UTC
Created attachment 97779 [details]
System Monitor miss reading I think

Comment 4 Erich Hoover 2004-02-25 02:17:45 UTC
I have the same problem: reproducible always.

For me it shows that I have ~100K of memory and ~10K of swap when I
have 512MB of memory (KDE reports 503.72) and 1024MB of swap (KDE
reports 1019.71).

Comment 5 Erich Hoover 2004-02-28 01:10:17 UTC
The latest updates from up2date fix the problem, thanks!

Comment 6 Scott Sloan 2004-02-28 06:33:47 UTC
I have been unable to confirm that this is fix since my FC2 machine 
died from a failed master harddrive. Erich says it's fix, got to 
trust the man. :) Thanks Erich for testing and reporting. :)

Good work everyone and another bug closed!


Note You need to log in before you can comment on or make changes to this bug.