Bug 1159304 - New host form errors after validation error
Summary: New host form errors after validation error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-31 12:47 UTC by Tom McKay
Modified: 2019-09-25 20:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:46:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug output (979.38 KB, application/x-xz)
2014-10-31 13:47 UTC, Jason Montleon
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 8230 None None None 2016-04-22 15:03:01 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Tom McKay 2014-10-31 12:47:06 UTC
While attempting to create a new host on Sat-6.0.4, I entered a Name "thomasmckay-sam" that had already been taken; proper validation red error box appeared. I then changed the name to "rpi-sam" in the form to a unique one and submitted again. The following appeared

<pre>
Failed to create a compute rhevm1.satellite.lab.eng.rdu2.redhat.com (RHEV) instance rpi-sam.released-el7.satellite.lab.eng.rdu2.redhat.com: Name must be formed of alphanumeric characters, numbers or "-_.".
</pre>

This leads, of course, to a situation where the entire new form must be reloaded and all values re-entered. After that the "rpi-sam" name works fine.

Comment 1 Tom McKay 2014-10-31 12:47:08 UTC
Created from redmine issue http://projects.theforeman.org/issues/8230

Comment 3 Jason Montleon 2014-10-31 13:47:54 UTC
Created attachment 952509 [details]
foreman-debug output

Comment 4 Bryan Kearney 2015-08-25 18:32:30 UTC
Upstream bug component is Hosts

Comment 5 Tomer Brisker 2016-03-17 09:36:06 UTC
I could not reproduce in current upstream - attempted to create a host with existing name, got validation error, changed name, host was created with no problem.
From upstream discussion appears the second failure (after changing the duplicate name) was caused by an invalid name given to RHEV leading to the failure and was unrelated to the previous failure.
Moving to ON_QA for verification.

Comment 7 Tazim Kolhar 2016-04-05 05:51:39 UTC
VERIFIED:
# rpm -q foreman
foreman-1.11.0.9-1.el7sat.noarch


Steps:

Please, note here I checked only name "test6-sam" is accepted by the form or not
https://cisco-b200m1-03.rhts.eng.bos.redhat.com/hosts/test6-sam.rhts.eng.bos.redhat.com

I am not sure whether the instance is created or not properly

There was no need to reload the form and re-enter the values

Comment 8 Tazim Kolhar 2016-04-05 06:05:08 UTC
Please note,

Here are the steps:

Create a host with a name already been taken.
It gives error : Name "test7-sam" that had already been taken

Then, I changed the name to "test8-sam". There was no 
need to load the form again
All other values were retained

Comment 11 errata-xmlrpc 2016-07-27 08:46:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.