Bug 115931 - Kanji key should be alt +, not shift +
Summary: Kanji key should be alt +, not shift +
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-17 07:24 UTC by Akira TAGOH
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 14:20:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff file between FC2 and Debian (1.30 KB, patch)
2004-02-17 07:25 UTC, Akira TAGOH
no flags Details | Diff

Description Akira TAGOH 2004-02-17 07:24:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.1)
Gecko/20031114

Description of problem:
on Windows, Kanji key is activated against Alt + Zenkaku_Hankaku key.
but on FC2, it's activated against Shift + Zenkaku_Hankaku key. it's
confusing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.press Alt+Zenkaku_Hankaku key on the keyboard, which have it
2.
3.
    

Actual Results:  key event is notified as Zenkanu_Hankaku

Expected Results:  key event should be notified as Kanji

Additional info:

This works on Debian's XFree86. I'll attach a diff related.

Comment 1 Akira TAGOH 2004-02-17 07:26:00 UTC
Created attachment 97729 [details]
diff file between FC2 and Debian

Comment 2 Akira TAGOH 2004-02-18 01:35:06 UTC
Hmm, I just wanted to do this to improve the usability for XIM. but I
would suspend this, because it causes another problem; gtk+ eats Alt
key as the accelerator faster than XIM. so it won't works right now
after this is changed..


Note You need to log in before you can comment on or make changes to this bug.