Bug 1159366 - Does not show standard (Fedora/gnome) icons as replacements for missing icons of configured theme (e.g. oxygen) [Xfce|LxQt]
Summary: Does not show standard (Fedora/gnome) icons as replacements for missing icons...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-settings
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1159359 (view as bug list)
Depends On: 1159359
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-31 16:44 UTC by Raphael Groner
Modified: 2015-02-25 21:59 UTC (History)
11 users (show)

(edit)
Clone Of: 1159359
(edit)
Last Closed: 2015-02-25 21:59:09 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 9992 None None None Never
Red Hat Bugzilla 1176115 None None None Never

Internal Trackers: 1176115

Description Raphael Groner 2014-10-31 16:44:35 UTC
Description of problem:
Xfce does not show hicolor icons as replacements for missing oxygen icons. For instance, the clipman plugin button has no icon.

Version-Release number of selected component (if applicable):
oxygen-icon-theme-4.14.2-1.fc20.noarch
oxygen-icon-theme-4.14.1-1.fc20.noarch

How reproducible:
yes

Steps to Reproduce:
1. switch to oxygen icon theme in Xfce settings
2. 
3. 

Actual results:
Buttons with no standard icons: Clipman plugin, backintime, gigolo, 'execute program', favorites (whisker menu), webbrowser (generic starter), xlock, …

Expected results:
Nice icons.

Additional info:
Severity high cause it may prevent good experience for new users.

+++ This bug was initially created as a clone of Bug #1159359 +++

Comment 1 Raphael Groner 2014-10-31 16:45:32 UTC
Notice to Xfce SIG, FYI.

Comment 2 Raphael Groner 2014-10-31 17:50:22 UTC
Sorry, confused the base themes.

You should add gnome to Inherits in index.theme, for reference take a look at elementary-xfce:

elementary-xfce]$ grep Inherits index.theme 
Inherits=gnome,hicolor

oxygen]$ grep Inherits index.theme 
Inherits=hicolor

Comment 3 Raphael Groner 2014-10-31 17:52:50 UTC
*** Bug 1159359 has been marked as a duplicate of this bug. ***

Comment 4 Raphael Groner 2014-10-31 18:32:15 UTC
Work around:

# sed -i s-hicolor-Fedora,hicolor- /usr/share/icons/oxygen/index.theme

Comment 5 Raphael Groner 2014-10-31 20:01:48 UTC
We may use gtk-fallback-icon-theme in xfsettingsd and a forced dependency to a theme like Fedora-icon-theme or Adwaita.

Comment 6 Rex Dieter 2014-11-11 18:03:49 UTC
Hrm, I found
https://developer.gnome.org/gtk3/stable/GtkSettings.html#GtkSettings--gtk-fallback-icon-theme

which suggests that setting is deprecated and ignored in recent gtk3 releases, so that workaround may not work (probably worth testing and verifying though)

Comment 7 Kevin Fenzi 2014-11-15 20:15:25 UTC
Yeah, testing would be great if someone could do that. ;) 

I'm not sure I will have time to do so anytime soon...

Comment 8 Raphael Groner 2015-01-30 20:49:56 UTC
This is also true for lxqt and Fedora 21. Any ideas for a goable work-around?

Comment 9 Raphael Groner 2015-01-30 21:01:21 UTC
*** Bug 1176115 has been marked as a duplicate of this bug. ***

Comment 10 Kevin Kofler 2015-02-25 17:56:55 UTC
GTK+ 3 now hardcodes the fallback to the GNOME icon theme. For GTK+ 2, use the gtk-fallback-icon-theme xsetting. Oxygen will not inherit from the GNOME or Fedora icon theme, it does not make sense outside of GTK+ applications.

Comment 11 Kevin Fenzi 2015-02-25 20:15:30 UTC
So, I am confused what you want me to do here. 

(BTW, please never clone bugs, it just makes everything confusing IMHO). 

I fixed gigolo. There's another bug for yumex. 

Can you file bugs on any others you see and we close this one?

Comment 12 Raphael Groner 2015-02-25 21:59:09 UTC
Maybe Yumex is fixed in the upcoming dnf version.


Note You need to log in before you can comment on or make changes to this bug.