Bug 115941 - displays using wrong encoding
Summary: displays using wrong encoding
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-17 10:34 UTC by Dimitri Papadopoulos
Modified: 2014-03-17 02:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 21:10:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2004-02-17 10:34:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Description of problem:
Fedora uses UTF-8 locales by default. In my case it's a French locale:
	# cat /etc/sysconfig/i18n
	LANG="fr_FR.UTF-8"
	[...]
	SYSFONT="latarcyrheb-sun16"
	# 

In some cases the init scripts seem to have problems with the encoding
of their output. In short I see uncorrectly some encoded messages on
the console while the services are being shut down:
	[...]
	Arrêt de NFS statd :           [OK]
	Arrêt de portmapper :           [OK]
	[...]


Version-Release number of selected component (if applicable):
initscripts-7.46-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Use an UTF-8 default locale with non-ASCII characters in message
strings (a locale such as fr_FR.UTF-8 will do).
2. Boot into runlevel 5.
3. Ctrl+Alt+F1
4. Ctrl+Alt+Del
5. Observe the messages from the services being shut down.

You won't be able to reproduce the problem if you shut down the system
the usual way:
1. Use an UTF-8 default locale with non-ASCII characters in message
strings (a locale such as fr_FR.UTF-8 will do).
2. Boot into runlevel 5.
3. Click on "Shutdown" or "Reboot"

It could be that a different locale (UTF-8 vs. Latin1) is used in
either cases, and that some scripts are capable of both Latin1 and
UTF-8, while some others are not?


Actual Results:
	Arrêt de NFS statd :           [OK]
	Arrêt de portmapper :           [OK]


Expected Results:
	Arrêt de NFS statd :            [OK]
	Arrêt de portmapper :           [OK]

Comment 1 Bill Nottingham 2004-02-17 15:59:34 UTC
$@&@&@&.

Will fix in CVS.


Comment 2 Bill Nottingham 2004-02-17 16:04:31 UTC
Hm, this works for me with LANG=fr_FR.UTF-8.  What sort of terminal
are you on?

Comment 3 Miloslav Trmac 2004-02-17 16:07:31 UTC
If this is the old problem, it occurs only on consoles
not set up to UTF-8 (i.e. nobody logged in), and
only as long as no initscript includes /etc/profile.d/lang.sh;
some initscripts (kudzu, portmap) include that file, which
sets up the console to UTF-8 and the following messages
look fine.

Comment 4 Dimitri Papadopoulos 2004-02-18 08:23:22 UTC
This is a Dell Precision 530 workstation.

And indeed there's nobody logged in when I shut down the machine, and
this seems to happen with initscripts that don't include
/etc/profile.d/lang.sh (the vast majority of them):

$ fgrep lang.sh /etc/init.d/*
/etc/init.d/kudzu:[ -f /etc/profile.d/lang.sh ] && .
/etc/profile.d/lang.sh
/etc/init.d/portmap:[ -f /etc/profile.d/lang.sh ] && .
/etc/profile.d/lang.sh
$ 


Comment 5 Dimitri Papadopoulos 2004-02-18 08:27:51 UTC
Sorry, this is actually a Dell Latitude CPx laptop.


Comment 6 Bill Nottingham 2005-09-30 21:10:57 UTC
This was a kernel bug with initialization of the console... it *should* be fixed
on FC4 + kernel 2.6.13.


Note You need to log in before you can comment on or make changes to this bug.