Bug 1159732 - [virtio-win][vioscsi]guest shutdown instead of S3/S4 while doing S3/S4 in guest
Summary: [virtio-win][vioscsi]guest shutdown instead of S3/S4 while doing S3/S4 in guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: Virt-S3/S4-7.0
TreeView+ depends on / blocked
 
Reported: 2014-11-03 08:06 UTC by lijin
Modified: 2015-11-24 08:46 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:46:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description lijin 2014-11-03 08:06:18 UTC
Description of problem:
do s3/s4 in guest,guest will shutdown instead of s3/s4.
we hit this issue with both spice(s3 and s4) and vnc(s4)

Version-Release number of selected component (if applicable):
kernel-3.10.0-196.el7.x86_64
qemu-kvm-rhev-2.1.2-5.el7.x86_64
seabios-1.7.5-5.el7.x86_64
virtio-win-prewhql-92
qxlwddm-0.1-6

How reproducible:
100%

Steps to Reproduce:
1.boot guest with spice OR vnc
/usr/libexec/qemu-kvm -smp 2 -m 2G -cpu SandyBridge -M pc -drive file=win8.1-32.qcow2,if=none,cache=none,format=qcow2,id=drive2,serial=abcdefghijklmnopqrstuvwxyz -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=drive2,bus=scsi0.0,id=disk-scsi -drive file=test.raw,if=none,cache=none,format=raw,id=drive3,media=disk -device scsi-hd,drive=drive3,bus=scsi0.0,id=disk-scsi1 -netdev tap,script=/etc/qemu-ifup,id=hostnet1 -device e1000,netdev=hostnet1,mac=00:52:54:00:22:88,id=net1 -usb -device usb-tablet -boot menu=on -monitor stdio -qmp tcp:0:4444,server,nowait -drive file=virtio-win-prewhql-0.1-92.iso,media=cdrom,if=none,cache=none,id=drive1 -device scsi-cd,drive=drive1,bus=scsi0.0,id=cdrom -drive file=virtio-win-prewhql-0.1-92.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 \
-spice disable-ticketing,port=5900 -vga qxl -global qxl-vga.revision=3
###OR####
-vnc :0 -vga cirrus 

2.do s3/s4 in guest(guest need to install qxlwddm driver in order to do S3)

3.resume guest(boot guest with the same command as step1)

Actual results:
after step2,guest shutdown instead of s3/s4
after step3,guest was not resumed,it was just a new boot(applications opened before were all gone).

Expected results:
guest can S3/S4 and resume correctly.

Additional info:

Comment 3 juzhang 2014-11-04 01:36:47 UTC
(In reply to Hai Huang from comment #2)
> This test case was done with Windows 8.1 guest.
> 
> Would you please test and confirm whether this problem
> exists for RHEL7 guest as well (or is this problem
> with the Windows guest).
> 
> Thanks.

Lijin,

Would you test it and update your testing result?

Best Regards,
Junyi

Comment 4 lijin 2014-11-04 07:18:28 UTC
(In reply to juzhang from comment #3)
> (In reply to Hai Huang from comment #2)
> > This test case was done with Windows 8.1 guest.
> > 
> > Would you please test and confirm whether this problem
> > exists for RHEL7 guest as well (or is this problem
> > with the Windows guest).
> > 
> > Thanks.
> 
> Lijin,
> 
> Would you test it and update your testing result?
> 
> Best Regards,
> Junyi

rhel7 guest can do s3/s4 correctly.

win8.1-32/win2012 can reproduce this problem,guest shutdown when do s3/s4;
win7-32 can do s3 correctly,but bsod(internal_power_error) when do s4,no dump generated.

change system disk from scsi to ide disk,the issue disappeared,so change the component to virtio-win.

Thanks a lot.

Comment 5 Mike Cao 2014-11-04 07:46:32 UTC
(In reply to lijin from comment #4)
> (In reply to juzhang from comment #3)
> > (In reply to Hai Huang from comment #2)
> > > This test case was done with Windows 8.1 guest.
> > > 
> > > Would you please test and confirm whether this problem
> > > exists for RHEL7 guest as well (or is this problem
> > > with the Windows guest).
> > > 
> > > Thanks.
> > 
> > Lijin,
> > 
> > Would you test it and update your testing result?
> > 
> > Best Regards,
> > Junyi
> 
> rhel7 guest can do s3/s4 correctly.
> 
> win8.1-32/win2012 can reproduce this problem,guest shutdown when do s3/s4;
> win7-32 can do s3 correctly,but bsod(internal_power_error) when do s4,no
> dump generated.
> 
> change system disk from scsi to ide disk,the issue disappeared,so change the
> component to virtio-win.
> 
> Thanks a lot.

Pls retest this issue with IDE drive to evaluate whether it is virtio-scsi issue

Comment 6 Mike Cao 2014-11-04 08:04:20 UTC
(In reply to Mike Cao from comment #5)
> (In reply to lijin from comment #4)
> > (In reply to juzhang from comment #3)
> > > (In reply to Hai Huang from comment #2)
> > > > This test case was done with Windows 8.1 guest.
> > > > 
> > > > Would you please test and confirm whether this problem
> > > > exists for RHEL7 guest as well (or is this problem
> > > > with the Windows guest).
> > > > 
> > > > Thanks.
> > > 
> > > Lijin,
> > > 
> > > Would you test it and update your testing result?
> > > 
> > > Best Regards,
> > > Junyi
> > 
> > rhel7 guest can do s3/s4 correctly.
> > 
> > win8.1-32/win2012 can reproduce this problem,guest shutdown when do s3/s4;
> > win7-32 can do s3 correctly,but bsod(internal_power_error) when do s4,no
> > dump generated.
> > 
> > change system disk from scsi to ide disk,the issue disappeared,so change the
> > component to virtio-win.
> > 
> > Thanks a lot.
> 
> Pls retest this issue with IDE drive to evaluate whether it is virtio-scsi
> issue

Looks Comment #4 resolved my concern 

Mke

Comment 7 Vadim Rozenfeld 2014-11-05 05:51:01 UTC
Can we try reproducing the problem with driver from build 88 ?

Thanks,
Vadim.

Comment 8 lijin 2014-11-05 06:57:53 UTC
(In reply to Vadim Rozenfeld from comment #7)
> Can we try reproducing the problem with driver from build 88 ?
> 
> Thanks,
> Vadim.

try with buil88,guest can s4 correctly

Comment 9 Vadim Rozenfeld 2014-11-05 07:22:15 UTC
Many thanks for your prompt response.
Vadim.

Comment 10 Vadim Rozenfeld 2014-12-07 01:55:13 UTC
Should be fixed in build 94.

Comment 13 Vadim Rozenfeld 2015-05-28 01:51:45 UTC
Can we recheck this problem with the latest build?
Thanks,
Vadim.

Comment 14 lijin 2015-05-29 08:14:57 UTC
Reproduced this issue on build 92
Verified this issue on build 104

steps same as comment #0

package  info:
kernel-3.10.0-223.el7.x86_64
qemu-kvm-rhev-2.1.2-17.el7.x86_64
seabios-1.7.5-8.el7.x86_64
spice-server-0.12.4-9.el7.x86_64

Actual Results:
on build 92, guest keep black screen after do s3/s4,and qemu doesn't quit after s4;
on build 104, guest can do s3/s4 correctly.

Based on above,this issue has been fixed already.

Comment 16 errata-xmlrpc 2015-11-24 08:46:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.