Bug 115974 - can't probe monitor on Dell Latitude CPx laptop
Summary: can't probe monitor on Dell Latitude CPx laptop
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-17 12:51 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 16:01:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/XFree86.0.log (35.93 KB, text/plain)
2004-02-20 17:01 UTC, Dimitri Papadopoulos
no flags Details

Description Dimitri Papadopoulos 2004-02-17 12:51:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Description of problem:
The installation process is unable to probe the monitor of a Dell
Latitude CPx laptop.

The video card is an ATI Technologies Inc Rage Mobility P/M AGP 2x.
The monitor is a 1024x768 TFT display. Details here:
http://docs.us.dell.com/docs/Systems/pcpxhj/en/ug_a02/specs.htm


Version-Release number of selected component (if applicable):
XFree86-4.3.0-45.0.1

How reproducible:
Always

Comment 1 Dimitri Papadopoulos 2004-02-17 13:03:37 UTC
	# system-config-xfree86 --reconfig
	* ddcprobe returned bogus values:
	ID:   None
	Name: None
	HorizSync: None
	VertSync:  None
	
	Trying with card: ATI Rage Mobility
	# 


Comment 2 Mike A. Harris 2004-02-17 14:57:37 UTC
That's not part of XFree86.

Reassigning...

Comment 3 Brent Fox 2004-02-20 00:59:56 UTC
Does system-config-display actually start at all?

Comment 4 Dimitri Papadopoulos 2004-02-20 08:39:48 UTC
Yes, it starts without problem. It just can't recognize the monitor.


Comment 5 Brent Fox 2004-02-20 16:01:58 UTC
Ok, good.  Some LCDs (especially some older laptops) don't have the
ability to be ddcprobed.  Since there's no way to tell what kind of
monitor it is, we try to use some generally safe sync rates so that
the program will start.

Then you can go into the Monitor dialog and select the correct model.
 Other than that, there's nothing we can do to fix the problem since
we can't get any probing information from the hardware.

Comment 6 Dimitri Papadopoulos 2004-02-20 16:27:17 UTC
Ah, OK. I seem to recall this used to work with Red Hat Linux 9, which
is why I've reported the bug. However I'm not 100% sure about that, I
could be wrong. If you think the problem is that the monitor is not
DDC capable, there's indeed no point in looking into this.


Comment 7 Mike A. Harris 2004-02-20 16:38:08 UTC
Dimitri: could you attach your X server log?

Comment 8 Dimitri Papadopoulos 2004-02-20 17:01:27 UTC
Created attachment 97860 [details]
/var/log/XFree86.0.log

mmmh.. DDC is supported supposedly supported, but the DDC read fails for
XFree86 as well:
	...
	(II) ATI(0): VESA VBE DDC supported
	(II) ATI(0): VESA VBE DDC Level none
	(II) ATI(0): VESA VBE DDC transfer in appr. 2 sec.
	(II) ATI(0): VESA VBE DDC read failed
	...


Note You need to log in before you can comment on or make changes to this bug.