Bug 1159771 - Wrong error message in New Connector wizard
Summary: Wrong error message in New Connector wizard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER1
: EAP 6.4.0
Assignee: Heiko Braun
QA Contact: Pavel Jelinek
URL:
Whiteboard:
Depends On:
Blocks: 1176535
TreeView+ depends on / blocked
 
Reported: 2014-11-03 09:58 UTC by Jakub Cechacek
Modified: 2019-08-19 12:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 12:42:06 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot (29.75 KB, image/png)
2014-11-07 12:52 UTC, Jakub Cechacek
no flags Details

Description Jakub Cechacek 2014-11-03 09:58:15 UTC
1) Navigate to: Configuration -> Web -> Servlet/HTTP -> Connectors
2) Click add button


Validation on "Socket Binding" Field behaves in a weird way. If correct socket binding is provided a  "Invalid input: no whitespace, no special chars" error message is displayed. The message seems to be displayed only when input shorter then 5 characters is entered or Every other field is filled in and "Socket Binding" contains an invalid value. 

Please contact me directly if more information is needed. This seems to be one of those UI related issues which are difficult to describe.

Comment 3 Jakub Cechacek 2014-11-07 12:51:44 UTC
I am able to reproduce this in both FF and Chrome (v 37). Have a look at attached screenshot

Comment 4 Jakub Cechacek 2014-11-07 12:52:14 UTC
Created attachment 954917 [details]
Screenshot

Comment 5 Heiko Braun 2014-11-10 14:34:13 UTC
I still cannot reproduce the issue.

Comment 6 Jakub Cechacek 2014-11-20 10:39:59 UTC
I am able to reproduce this even with DR10 and 2.4.7 using the following input

Name: foo
Socket Bindings: http
protocol: HTTP/1.1
Scheme: http
Enabled?: true


After attempting to save the wizard "Socket Binding" field will yield this validation error: "Invalid input: no whitespace, no special chars".

Comment 8 Heiko Braun 2014-12-18 10:11:39 UTC
The error message is wrong: it should read "Socket binding already in use"

Comment 9 Pavel Jelinek 2015-01-14 15:48:27 UTC
Verified for EAP 6.4.0.ER1.


Note You need to log in before you can comment on or make changes to this bug.