Bug 115983 - 'Use context' drop down doesn't pick up new entries once server is started
Summary: 'Use context' drop down doesn't pick up new entries once server is started
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Scott Seago
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-02-17 14:17 UTC by Daniel Berrange
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 20:17:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2004-02-17 14:17:54 UTC
Description of problem:
When creating a JSP template for a content type, there is a down down
list box populated with TemplateContext objects. It appears, however,
that this is populated at page creation time, rather than pre-request,
so when new contexts are created they never appear until the next
server restart. This severly impacts on the APLAWS subsite &
navigation applications, since they both make heavy use of
TemplateContext objects - creating, editing & deleting them at runtime.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new subsite
2. GO to /ccm/content/admin
3. Select 'add template' link
  
Actual results:
New subsite does not appear in template context drop down

Expected results:
New subsite appears.

Additional info:

Comment 1 Scott Seago 2004-02-17 19:45:32 UTC
Moved SingleSelect population to a PrintListener @40483


Note You need to log in before you can comment on or make changes to this bug.