Bug 115984 - Upgrade from samba-3.0.2-1rc1 to 3.0.2-5 broke samba: cannot log in no more
Summary: Upgrade from samba-3.0.2-1rc1 to 3.0.2-5 broke samba: cannot log in no more
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-17 14:22 UTC by Ville Herva
Modified: 2014-08-31 23:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 03:30:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/samba/smb.conf (10.20 KB, text/plain)
2004-02-17 20:53 UTC, Ville Herva
no flags Details

Description Ville Herva 2004-02-17 14:22:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040115 Firebird/0.8.0+

Description of problem:
Last night, yum upgraded my samba from samba-3.0.2-1rc1 to 3.0.2-5
(from fedora.redhat.com/pub/fedora/linux/core/d
evelopment). 

Since then I can't log in no more. It keeps rejecting my password. The
curious thing is, I can't find anything in the samba logs nor in
/var/log/messages.

I went back to samba-3.0.2-1rc1 and everything works again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade to 3.0.2-5
2.
3.
    

Additional info:

Comment 1 Jay Fenlason 2004-02-17 17:18:05 UTC
At the very least I'll need a copy of your /etc/samba/smb.conf and a
better description of your Windows network configuration before I'll
have any chance at all of debugging this.

Comment 2 Ville Herva 2004-02-17 20:53:12 UTC
Created attachment 97764 [details]
/etc/samba/smb.conf

Comment 3 Ville Herva 2004-02-17 21:00:37 UTC
Yes, sorry for being curt. I meant to provide more info, but then got
drawn to other tasks.

I attached the smb.conf (changed a few host names and ip addresses to
protect the innocent.)

I tried connecting from XP SP1, and another Fedora Core 1 box with
smbclient. 

I tried resetting the smb user passwd with smbpasswd, didn't help.

The allow hosts line seems not to be the culprit: if I connect from
disallowed host, I _do_ get a log entry into /var/log/messages.

And *just* backing samba, samba-common and samba-client from 
3.0.2-5 to 3.0.2-1rc1 makes it work again.

I have this sneaking suspicion that this is connected to the selinux
libraries. I run almost full Fedora development distro, but I still
have 2.4.x kernel without selinux support. Might the have been some
changes in samba wrt this samba-3.0.2-1rc1 to 3.0.2-5?

Comment 4 Jay Fenlason 2004-02-17 21:10:21 UTC
I just saw an interesting message:
http://lists.samba.org/archive/samba/2004-February/080901.html
Can you look at your smbpasswd file and see if perhaps this is
describing your problem?

Comment 5 Ville Herva 2004-02-17 21:28:21 UTC
This is exactly the problem I had.  Still wondering why it didn't log
anything, but I'm happy with the problem solved.

This sort of support the best I could ever have hoped for. I should
give you a virtual gold star :).


Comment 6 Jeremy Katz 2004-05-07 03:30:37 UTC
Closing per information provided.


Note You need to log in before you can comment on or make changes to this bug.