Bug 116003 - Cannot copy item to another folder
Cannot copy item to another folder
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Daniel Berrange
:
Depends On: 116119
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-17 10:31 EST by Arturo Dell
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 11:44:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arturo Dell 2004-02-17 10:31:45 EST
Description of problem: Cannot copy an item to another folder


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Go to any folder
2. Select an item (click on the checkbox)
3. Select 'copy' on 'Copy or move checked items:' form widget then 
click go on the submit button
4. Choose the destination category
5. Click Save.
  
Actual results: 500 Servlet Exception

com.arsdigita.util.AssertionError: com.arsdigita.cms.ContentType is 
null
Comment 1 Scott Seago 2004-02-17 13:07:12 EST
I can't reproduce this. I just copied two articles to a subfolder, one
of which was published and another had not been published.

From the look of the error message, it looks like you may have some
content items with the ContentType field missing.

It's possible that this bug has already been resolved as a side effect
of another bug fix.
Comment 2 Daniel Berrange 2004-02-17 13:12:19 EST
We saw this behaviour when we initially tested the bulk import, but I
thought we'd fixed the persistence/beforeSave event bug causing it.
I'll investigate further on their production servers.
Comment 3 Daniel Berrange 2004-02-23 07:20:48 EST
This is resolved on staging - please verify & update this ticket if
its working acceptably.

Note You need to log in before you can comment on or make changes to this bug.