Bug 1160078 - python-importlib incorrectly Conflicts with python(abi)=2.7
Summary: python-importlib incorrectly Conflicts with python(abi)=2.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-importlib
Version: el6
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Andrew Colin Kissa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-03 23:47 UTC by vitaminmoo@wza.us
Modified: 2017-07-26 17:16 UTC (History)
6 users (show)

Fixed In Version: python-importlib-1.0.4-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-26 17:16:40 UTC


Attachments (Terms of Use)

Description vitaminmoo@wza.us 2014-11-03 23:47:24 UTC
Description of problem:

python-importlib appears to have a hard 'Conflicts: python(abi)=2.7'. This may prevent installation alongside epel7 default python, but it also causes conflicts with well-formed third party python27 packages for epel6. I believe the autodep created 'Requires: python(abi)=2.6' is enough to prevent installation with python 2.7 on epel7, as the requirement will not be satisfied. If I'm not missing anything, I think the Conflicts could be removed without ill effect.

Note that all non-documentation files in python-importlib are contained in /usr/lib/python2.6, effectively ensuring that it will not actually conflict with a properly namespaced python2.7 package installed simultaneously.

Regarding the documentation files, no python27 importlib package will ever exist as it's included in the main distribution.

[root@vm ~]# repoquery --list python-importlib
/usr/lib/python2.6/site-packages/importlib
/usr/lib/python2.6/site-packages/importlib-1.0.2-py2.6.egg-info
/usr/lib/python2.6/site-packages/importlib/__init__.py
/usr/lib/python2.6/site-packages/importlib/__init__.pyc
/usr/lib/python2.6/site-packages/importlib/__init__.pyo
/usr/share/doc/python-importlib-1.0.2
/usr/share/doc/python-importlib-1.0.2/README

Version-Release number of selected component (if applicable):

1.0.2-1.el6

How reproducible:


Steps to Reproduce:
1. Install a third party package that provides python(abi)=2.7
2. yum install python-importlib

Actual results:

Loaded plugins: fastestmirror, security, versionlock
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-importlib.noarch 0:1.0.2-1.el6 will be installed
--> Processing Conflict: python-importlib-1.0.2-1.el6.noarch conflicts python(abi) = 2.7
--> Finished Dependency Resolution
Error: python-importlib conflicts with python27-2.7.2-ua26.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Normally installed python-importlib for system python 2.6

Additional info:

Note that this does not to my knowledge cause any issues with any CentOS or EPEL6 packages, however, it doesn't seem to provide much benefit, and causes custom python27 RPMs to have to mess with autoprov to prevent conflicts.

Comment 1 Carl George 2016-02-17 16:56:03 UTC
This affects the IUS repository.  We ship parallel python27 packages, and there are no file conflicts with python-importlib, but python-importlib is not installable at the same time due to the unnecessary conflict.

I can fix this for you if you add me as a maintainer.  My FAS username is carlgeorge.

Comment 2 Fedora Update System 2017-07-06 04:11:07 UTC
python-importlib-1.0.4-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-30f1741817

Comment 3 Fedora Update System 2017-07-07 07:48:31 UTC
python-importlib-1.0.4-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-30f1741817

Comment 4 Fedora Update System 2017-07-26 17:16:40 UTC
python-importlib-1.0.4-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.