Bug 116009 - MAKEDEV binary should not be in /dev
Summary: MAKEDEV binary should not be in /dev
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: MAKEDEV   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-17 16:12 UTC by Enrico Scholz
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version: 3.8.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 00:15:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2004-02-17 16:12:11 UTC
Description of problem:

MAKDEV places the 'MAKEDEV' binary into /dev. This is bad because:

* this binary will be missing on systems with devfs 
* this binary will be missing on systems with special requirements 
  regarding /dev; e.g. the fedora.us buildsystem has 
  '%_netsharedpath /dev' (--> nothing inside /dev will be created)

Since MAKEDEV is not used to create /dev entries only, but to create
%attr() entries from rpm-specfiles (-M option), package build will 
fail on the systems above.

My suggestion:
Please move the MAKEDEV binary into /sbin, and create a symlink to
/dev/MAKEDEV. Such a symlink can be created easily on the systems
mentioned above.

The %pre check for devfs can be removed too when doing this.


Version-Release number of selected component (if applicable):

MAKEDEV-3.3.12-1

Comment 1 Harald Hoyer 2004-08-26 10:45:48 UTC
yes, please make this happen!


Note You need to log in before you can comment on or make changes to this bug.