Bug 1160154 - C++ and .NET clients on Windows do not support AMQP 1.0 protocol
Summary: C++ and .NET clients on Windows do not support AMQP 1.0 protocol
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Windows
high
high
Target Milestone: 3.1
: ---
Assignee: Chuck Rolke
QA Contact: Petra Svobodová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-04 07:41 UTC by Petra Svobodová
Modified: 2015-04-14 13:48 UTC (History)
4 users (show)

Fixed In Version: qpid-cpp-0.30-4
Doc Type: Bug Fix
Doc Text:
It was discovered that a build script did not include the Proton shared install directory. AMQP 1.0 support delivered by Proton was absent. The fix adds the framework code to specify and use the Proton shared install directory. AMQP 1.0 support is now available in the Microsoft Windows SDK.
Clone Of:
Environment:
Last Closed: 2015-04-14 13:48:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petra Svobodová 2014-11-04 07:41:09 UTC
Description of problem:
C++ and .NET clients on Windows platform are able to send or receive messages over AMQP 0-10 protocol, but with AMQP 1.0 protocol fail.

Version-Release number of selected component (if applicable):
qpid-cpp-win-3.30.3.1-1

How reproducible:
100%

Steps to Reproduce:
1. Unzip the qpid-cpp-package and build C++ and C# examples.
2. Run a broker on a Linux machine.
3. Try to send a message: csharp.example.spout.exe --broker <brk_hostname:port> --connection-options "{protocol:amqp1.0}" amq.fanout

Actual results:
Qpid exception "Unsopported protocol" is raised (see below, please).

Expected results:
The message should be delivered and the client should be closed with no exceptions.

Additional info:
Windows command line transcript;

C:\qpid_VS2010\bin\Release>csharp.example.spout.exe --broker 10.34.33.199:5672 -
-connection-options {protocol:amqp1.0} amq.fanout
Exception Org.Apache.Qpid.Messaging.QpidException: Unsupported protocol: amqp1.0

   at Org.Apache.Qpid.Messaging.Connection..ctor(String url, String options) in
q:\qpid\cpp\bindings\qpid\dotnet\src\connection.cpp:line 123
   at Org.Apache.Qpid.Messaging.Examples.Spout.Main(String[] args) in c:\qpid_VS
2010\dotnet_examples\examples\csharp.example.spout\csharp.example.spout.cs:line
69.

Comment 1 Petra Svobodová 2014-11-04 12:45:43 UTC
The issue may be caused by missing "qpid-proton.dll" library in the qpid-cpp-win package.

Comment 4 Chuck Rolke 2014-11-05 22:08:13 UTC
Build script fixed upstream in Committed revision 1636981.

Comment 7 Petra Svobodová 2014-12-04 07:33:11 UTC
Now both clients on Windows (C++ and C#) support communication via AMQP 1.0 protocol.

Verified on packages qpid-cpp-win-3.30.4.1-1 for Microsoft Visual Studio 2008 and 2010 on Windows7-x64, Windows8-x64, Windows Server2008-x64, Windows Server2008 R2 and Windows Server2012 R2 platforms.

--> VERIFIED

Comment 11 errata-xmlrpc 2015-04-14 13:48:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.