Bug 1160191 - Able to create New support case in JBoss ON who does not have 'Manage Support Cases' permission
Summary: Able to create New support case in JBoss ON who does not have 'Manage Support...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Red Hat Access
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: CR01
: JON 3.3.1
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-11
TreeView+ depends on / blocked
 
Reported: 2014-11-04 09:39 UTC by Jeeva Kandasamy
Modified: 2015-11-02 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-27 19:58:35 UTC
Type: Bug


Attachments (Terms of Use)
screen shot (73.00 KB, image/jpeg)
2014-11-04 09:39 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-11-04 09:39:42 UTC
Created attachment 953507 [details]
screen shot

Description of problem:
Able to create new support case who does not have 'Manage Support Cases' permission.

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.CR01
Build Number : 08c2f39:6ac97ac
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 33

How reproducible:
always

Steps to Reproduce:
1. Login in to JBOSS ON 3.3
2. Login in to 'Red Hat access' with the user, who does not have 'Manage Support Cases' permission.
3. Open new support case.


Actual results:
Able to create new support case

Expected results:
Who does not have permission, should not allow to create new support case. 

Additional info: Screen shot is attached.

Comment 4 Libor Zoubek 2015-01-18 08:50:19 UTC
Also we need to make sure to rename all new *.js and *.css files (custom-cases.js -> custom-cases-redhat-1.js)

Comment 5 Simeon Pinder 2015-01-19 20:53:00 UTC
Moving into CR01 target milestone as missed ER01 cutoff.

Comment 6 Libor Zoubek 2015-01-29 16:38:48 UTC
Updated angular app should fix this bug

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/22a1dad19
time:    2015-01-29 17:36:35 +0100
commit:  22a1dad1933a25bf3b4731873a663760a3436671
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1160191 - Able to create New support case in JBoss ON who does not
         have
         'Manage Support Cases' permission
         Updated RHA to 0.9.73. All files changed since 3.3.0.GA had to
         be renamed
         (prevent browser caching) added CacheFilter class which sets
         correct headers to returned js,css,html files - so we don't
         need to rename files with further updates.

Comment 7 Simeon Pinder 2015-02-16 04:49:39 UTC
Moving to ON_QA as available to test with latest CP build:
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/16/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
*Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of jon-server-3.3.0.GA-update-01.zip.

Comment 8 Jeeva Kandasamy 2015-02-16 13:01:51 UTC
Verified, user unable to create new support case. But it's allowing user to enter data till to reach submit page. I have create a low priority BZ(https://bugzilla.redhat.com/show_bug.cgi?id=1193042) to track this issue. 

Version:
JBoss Operations Network
Version : 3.3.0.GA Update 01
Build Number : ab9ebbd:884011b
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 35.0


Note You need to log in before you can comment on or make changes to this bug.