Bug 1160279 - module-ews-ui-config.so: undefined symbol: session
Summary: module-ews-ui-config.so: undefined symbol: session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-exchange
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-04 13:49 UTC by Siteshwar Vashisht
Modified: 2019-04-16 14:22 UTC (History)
5 users (show)

Fixed In Version: evolution-exchange-2.32.3-17.el6
Doc Type: Bug Fix
Doc Text:
Cause: Use Exchange Web Services (EWS) connector Consequence: The UI part of the connector fails to load due to missing external symbol Fix: Link also against a library which provides the missing symbol Result: The UI part of the EWS connector loads properly and the account can be configured
Clone Of:
Environment:
Last Closed: 2015-07-22 05:59:24 UTC


Attachments (Terms of Use)
evolution-ews-gnome-3-0.gitcc16df2-camel-session-global-variable.patch (733 bytes, patch)
2014-11-04 13:57 UTC, Milan Crha
no flags Details | Diff
evolution-ews-gnome-3-0.gitcc16df2-camel-session-global-variable.patch (1.12 KB, patch)
2014-11-05 13:36 UTC, Milan Crha
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1265 normal SHIPPED_LIVE evolution-exchange bug fix update 2015-07-20 17:49:40 UTC

Description Siteshwar Vashisht 2014-11-04 13:49:24 UTC
Description of problem:
evolution shows below message at startup :

(evolution:23128): e-utils-WARNING **: /usr/lib64/evolution/2.32/modules/module-ews-ui-config.so: undefined symbol: session
Failed to load module: /usr/lib64/evolution/2.32/modules/module-ews-ui-config.so

Version-Release number of selected component (if applicable):
evolution-exchange-2.32.3-16.el6.x86_64

How reproducible:
Always on specific system.

Steps to Reproduce:
1. Start evolution from terminal
2. Observe the output

Actual results:
'/usr/lib64/evolution/2.32/modules/module-ews-ui-config.so' fails to load.

Expected results:
'/usr/lib64/evolution/2.32/modules/module-ews-ui-config.so' should be loaded without any errors.

Additional info:

Comment 1 Milan Crha 2014-11-04 13:57:04 UTC
Created attachment 953604 [details]
evolution-ews-gnome-3-0.gitcc16df2-camel-session-global-variable.patch

Thanks for a bug report. This should fix the issue (even I'm not able to reproduce it myself, somehow). I built a test package witht he fix included at:

https://brewweb.devel.redhat.com/taskinfo?taskID=8194993

Give it a try and let me know whether it worked. Thanks in advance. Please do not forget to logout and log in after installing it, to make sure that the new binaries will be loaded.

Comment 2 Siteshwar Vashisht 2014-11-05 10:53:08 UTC
I am able to reproduce this issue by following below steps :

1. Setup a vanilla RHEL 6.5 system.
2. Install evolution-exchange package.
3. Do 'yum update' and update to latest version of all the packages.
4. Start evolution in terminal and observe the error message printed in terminal.

This issue is not reproducible on vanilla RHEL 6.6 system however.

Comment 3 Milan Crha 2014-11-05 13:36:39 UTC
Created attachment 954043 [details]
evolution-ews-gnome-3-0.gitcc16df2-camel-session-global-variable.patch

The problem seems to be somewhere else. Why updated machine has a problem, while vanila not is a question, but otherwise the reason might be that the external global variable is defined in a library against which the module doesn't link explicitely. This patch does exactly that.

Comment 14 errata-xmlrpc 2015-07-22 05:59:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1265.html


Note You need to log in before you can comment on or make changes to this bug.