Bug 116031 - libuser not rebuilt since FC2, CVS inaccessible?
libuser not rebuilt since FC2, CVS inaccessible?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libuser (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-02-17 13:34 EST by Ivan
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.51.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 08:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan 2004-02-17 13:34:05 EST
Description of problem:
.spec file missing a BuildPrereq

Version-Release number of selected component (if applicable):
libuser-0.51.7-7

How reproducible:
Always

Steps to Reproduce:
1. rpm -e glib2-devel
2. rpmbuild -bb libuser.spec
  
Actual results:
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 gmodule-2.0... Package glib-2.0 was not found in
the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

configure: error: Library requirements (glib-2.0 gmodule-2.0) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your
libraries are in a no nstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.40621 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.40621 (%build)

Expected results:
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 gmodule-2.0... yes
checking GLIB_CFLAGS... -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include  

Additional info:
the line
    BuildPrereq: glib2-devel
is missing
Comment 1 Matthias Saou 2004-07-22 14:56:18 EDT
I can confirm that this is still missing in the current
libuser-0.51.7-7.1.1 package.

Adding the EasyFix keyword, as this is definitely one :-)

I can also confirm that no other build depndencies are missing, as
long as gettext iss considered to be a basic package for building.
Comment 2 Warren Togami 2004-08-24 07:43:24 EDT
BuildRequires: glib2-devel, gettext
This is required to be added to libuser.spec.  However I am unable to
make that change now because I am unable to access the proper CVS
module located on rhlinux.redhat.com.

For some reason I do not understand, the latest-pkg of libuser in
rawhide is still the final libuser from FC2.

Additionally a local rebuild caused this change.  I don't know how
this may or may not impact the rest of the system.  This requires more
comment.  We should get this rebuilt however before FC3 test2.

--- before      2004-08-24 01:37:49.008783599 -1000
+++ after       2004-08-24 01:37:34.637276988 -1000
@@ -13,8 +13,8 @@
 libglib-2.0.so.0
 libgmodule-2.0.so.0
 libgobject-2.0.so.0
-liblber.so.2
-libldap.so.2
+liblber-2.2.so.7
+libldap-2.2.so.7
 libpam.so.0
 libpam_misc.so.0
 libpopt.so.0
Comment 3 Miloslav Trmač 2004-08-25 08:58:57 EDT
BuildRequires: glib2-devel added.
The dependency changes (BTW, Warren, you didn't say what you were
comparing in the diff) are fine, see #130583.
Comment 4 Warren Togami 2004-08-25 17:12:20 EDT
Oops, sorry.  That was the output of rpm -qp --requires.  I don't know
what impact that change would cause.

Note You need to log in before you can comment on or make changes to this bug.