Bug 1160493 - katello-cert-tools fails during katello-install due to openssl deps openssl-devl-1.0.1e-16.el6.5.15.x86_64.rpm and openssl-1.0.1e-16.el6_5.15.x86_64.rpm
Summary: katello-cert-tools fails during katello-install due to openssl deps openssl-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.0.4
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-05 00:38 UTC by Shadd
Modified: 2019-09-26 17:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:43:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Shadd 2014-11-05 00:38:40 UTC
Description of problem:
During Disconnected install from iso.

katello-cert-tools fails during katello-install due to openssl deps  openssl-devl-1.0.1e-16.el6.5.15.x86_64.rpm and openssl-1.0.1e-16.el6_5.15.x86_64.rpm


Version-Release number of selected component (if applicable):

Satellite 6.0.4


How reproducible:

Install RHEL 6.5 
Mount iso as repo 
Mount Sat 6.0.4 iso as repo 

Create local repo file in yum.repos.d
rhel_65_local.repo
katello-local.repo
scl.repo

add IP and hostname to /etc/hosts 
Follow Directions from RedHat documentation 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/Installation_Guide/Installing_Red_Hat_Satellite_with_an_ISO_Image.html


Steps to Reproduce:
1.
2.
3.

Actual results:
[root@sat604 Desktop]# cd /media/Satellite-6.0.4
[root@sat604 Satellite-6.0.4]# ls
addons            media.repo  README    RHSCL
install_packages  Packages    repodata  TRANS.TBL
[root@sat604 Satellite-6.0.4]# ./install_packages 
This script will install the katello packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Importing the gpg key.
   - katello is not yet installed, installing it.
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
   - Installation repository will remain configured for future package installs.
   - Installation media can now be safely unmounted.

Install is complete. Please run katello-installer.

[root@sat604 Satellite-6.0.4]# hostname
sat604
[root@sat604 Satellite-6.0.4]# vim /etc/sysconfig/network
[root@sat604 Satellite-6.0.4]# vim /etc/hosts
[root@sat604 Satellite-6.0.4]# hostname sat604.vm.lab
[root@sat604 Satellite-6.0.4]# katello-installer 

 Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (Satellite-6.0.4)
 /Stage[main]/Certs::Install/Package[katello-certs-tools]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (Satellite-6.0.4)
Installing             --- /etc/puppet/auth.confet::Conf2014-06-24 09:42:25.0000 [91%] [..................................... /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
 /Stage[main]/Candlepin::Service/Exec[cpinit]: Failed to call refresh: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
 /Stage[main]/Candlepin::Service/Exec[cpinit]: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]


Expected results:


Additional info:

Comment 2 Matt Reid 2014-12-04 22:05:16 UTC
We just hit this using a RHEL 6.5 x86_64 DVD as our source and trying to install Sat 6.0.4 disconnected using the Sat ISO.

katello-installer lists the following errors:

[ERROR 2014-12-05 06:11:25 main] Repeating errors encountered during run:
[ERROR 2014-12-05 06:11:25 main]  Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (katello-local)
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Certs::Install/Package[katello-certs-tools]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install katello-certs-tools' returned 1: Error: Package: katello-certs-tools-1.5.6-1.el6sat.noarch (katello-local)
[ERROR 2014-12-05 06:11:25 main]  Could not start Service[named]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait named start' returned 2: Starting named:
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Dns::Service/Service[named]/ensure: change from stopped to running failed: Could not start Service[named]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait named start' returned 2: Starting named:
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Candlepin::Service/Exec[cpinit]: Failed to call refresh: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Candlepin::Service/Exec[cpinit]: /usr/bin/wget --timeout=30 --tries=5 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 4 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
[ERROR 2014-12-05 06:11:25 main]  Could not find a suitable provider for certs_bootstrap_rpm
[DEBUG 2014-12-05 06:11:25 main] Cleaning /etc/katello-installer/d20141205-7368-1vttus7
[DEBUG 2014-12-05 06:11:25 main] Cleaning /tmp/default_values.yaml

Through subsequent install attempts, I was able to get the errors output to just the katello-certs-tools and "could not find a suitable provider for certs_bootstrap_rpm".

Comment 3 Brett Thurber 2014-12-04 22:31:31 UTC
FWIW - the package of concern in question (openssl-1.0.1e-15.el6.x86_64) ships with RHEL 6.5 base.  The product docs state that RHEL 6.5 or later as supported with Sat 6.  

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Prerequisites.html

The product docs will need to be modified/updated to reflect RHEL 6.6 and later.

Comment 4 Brett Thurber 2014-12-04 22:34:01 UTC
Doc bug reference:
https://bugzilla.redhat.com/show_bug.cgi?id=1169499

Comment 8 Sachin Ghai 2016-04-29 12:16:11 UTC
Verified with Satellite-6.2.0-RHEL-7-20160428.0 iso ( 6.2 beta)

[root@cloud-qe-3 ~]# ll -h Satellite-6.2.0-RHEL-7-20160428.0-Satellite-x86_64-dvd1.iso 
-rw-r--r--. 1 root root 1.9G Apr 28 05:42 Satellite-6.2.0-RHEL-7-20160428.0-Satellite-x86_64-dvd1.iso

# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta

]# ./install_packages 
This script will install the satellite packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Importing the gpg key.
   - Installation repository will remain configured for future package installs.
   - Installation media can now be safely unmounted.
[root@cloud-qe-3 mnt]# foreman-installer --scenario katello --foreman-admin-password changeme
Installing             Done                                               [100%] [..................................................................]
  Success!
  * Katello is running at https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com
      Initial credentials are admin / changeme
  * To install additional capsule on separate machine continue by running:
  
capsule-certs-generate --capsule-fqdn "$CAPSULE" --certs-tar "~/$CAPSULE-certs.tar"

  The full log is at /var/log/foreman-installer/katello.log

Comment 10 errata-xmlrpc 2016-07-27 08:43:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.