Bug 1160495 - Not sure how to get unittest2
Summary: Not sure how to get unittest2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Kuska
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1162484
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-05 01:42 UTC by Amit Saha
Modified: 2016-04-18 10:17 UTC (History)
16 users (show)

Fixed In Version: python-2.7.8-9.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-22 22:52:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Amit Saha 2014-11-05 01:42:28 UTC
Description of problem:

    > sudo yum -y install python-unittest2
    [sudo] password for asaha:
    Loaded plugins: langpacks
    Package python-2.7.8-5.fc21.x86_64 already installed and latest version
    Nothing to do
    ~/work/beaker (per_distro_netboot)> python
    Python 2.7.8 (default, Oct 27 2014, 15:54:28)
    [GCC 4.9.1 20140930 (Red Hat 4.9.1-11)] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import unittest2
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    ImportError: No module named unittest2
    >>>
     




Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. See above.
2.
3.

Actual results:


Expected results:

Usable unittest2.


Additional info:

Comment 1 Dan Callaghan 2015-04-09 00:10:59 UTC
This is effectively a dupe of bug 1161166, which is not fully fixed yet in spite of its CLOSED status.

Comment 2 Dan Callaghan 2015-04-15 07:09:20 UTC
Slavek, as per https://bugzilla.redhat.com/show_bug.cgi?id=1161166#c15 can you please drop the Provides/Obsoletes for python-unittest2 from python. This is breaking anything that requires unittest2 (including Beaker).

Comment 3 Robert Kuska 2015-04-15 09:56:48 UTC
Builds are in progress for F21+

Comment 4 Fedora Update System 2015-04-15 12:04:03 UTC
python-2.7.8-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-2.7.8-9.fc21

Comment 5 Robert Kuska 2015-04-15 12:05:26 UTC
Builds failed on F22 and rawhide because of the test_gdb, rebuilds are in progress.

Comment 6 Fedora Update System 2015-04-15 19:13:21 UTC
python-2.7.9-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-2.7.9-6.fc22

Comment 7 Fedora Update System 2015-04-17 18:36:13 UTC
Package python-2.7.9-6.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-2.7.9-6.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6230/python-2.7.9-6.fc22
then log in and leave karma (feedback).

Comment 8 Marek Zdunek 2015-04-19 09:02:51 UTC
Theres dependency problem with python-2.7.8-8.fc21.x86_64 and tkinter-2.7.8-8.fc21.x86_64

log:
Rozwiązywanie zależności
--> Wykonywanie sprawdzania transakcji
---> Pakiet python.x86_64 0:2.7.8-7.fc21 zostanie zaktualizowany
---> Pakiet python.x86_64 0:2.7.8-8.fc21 zostanie zaktualizowany
---> Pakiet python-libs.x86_64 0:2.7.8-7.fc21 zostanie zaktualizowany
---> Pakiet python-libs.x86_64 0:2.7.8-8.fc21 zostanie zaktualizowany
---> Pakiet tkinter.x86_64 0:2.7.8-7.fc21 zostanie zaktualizowany
---> Pakiet tkinter.x86_64 0:2.7.8-8.fc21 zostanie zaktualizowany
--> Przetwarzanie zależności: /bin/python dla pakietu: caffeine-2.8.2-14.1.noarch
--> Wykonywanie sprawdzania transakcji
---> Pakiet tkinter.x86_64 0:2.7.8-7.fc21 zostanie zaktualizowany
---> Pakiet tkinter.x86_64 0:2.7.8-8.fc21 zostanie zaktualizowany
--> Przetwarzanie zależności: python = 2.7.8-8.fc21 dla pakietu: tkinter-2.7.8-8.fc21.x86_64

Pakiety pominięto z powodu problemów z zależnościami:
    python-2.7.8-8.fc21.x86_64 z updates
    python-libs-2.7.8-8.fc21.x86_64 z updates
    tkinter-2.7.8-8.fc21.x86_64 z updates

Comment 9 Robert Kuska 2015-04-20 15:23:39 UTC
What command did you run? And where is caffeine from, can I see its specfile?

Comment 10 Marek Zdunek 2015-04-20 17:39:21 UTC
Ok its my mistake. I didn't saw that caffeine in log. I get it from corp.

Comment 11 Fedora Update System 2015-04-22 22:52:13 UTC
python-2.7.9-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-04-22 22:57:40 UTC
python-2.7.8-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.