Bug 116052 - 'base' and 'core' groups don't truly contain ALL necessary 'base' packages
Summary: 'base' and 'core' groups don't truly contain ALL necessary 'base' packages
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-17 21:50 UTC by Paul Pianta
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 23:22:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Pianta 2004-02-17 21:50:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
Hi this one is probably for Jeremy ...

I know you guys are super busy on getting anaconda to work well with 2.6 and FC2 but I have a ?simple? RFE ...

I am one of the guys helping out on the anaconda-documentation project at the moment and I was in the middle of rebuilding a custom version of Fedora when I realised the 'base' and 'core' package groups in the comps.xml file have quite a few other package dependencies.

I tested this by running a kickstart install with nothing in the %packages section and then compared what packages actually got installed to what packages are listed in 'base' and 'core' groups of comps.xml. 

I was hoping that maybe all necessary dependencies could be added into the base and/or core groups so there are no nasty dependency surprises when chopping down the RPMS forest ...

I am filing this against FC2 in the off chance that you might have time to modify it b4 the final release. I know its being a bit 'picky' but it can be misleading for new 'customizers' when trying to cut the distro down to the bare minimum and finding out that the bare minimum is *too* bare and more packages are needed ...

Version-Release number of selected component (if applicable):
Any comps.xml since RedHat-8

How reproducible:
Always

Steps to Reproduce:
1. Modify comps.xml
2. Reduce number of packages in RPMS directory
3.
    

Actual Results:  found out there are additional dependencies to the 'base' and 'core' groups ...

Expected Results:  all packages including their dependencies are listed in appropriate groups in comps.xml

Additional info:

No one else has yet managed to match the power, flexibility and ease of use of the anaconda/kickstart combo - good stuff fellas!!

Comment 1 Jeremy Katz 2004-02-17 23:22:05 UTC
Nope, anaconda resolves dependencies so that this list doesn't have to
be kept up to date.  We used to have to list out all deps explicitly
in the comps file and it was a maintenance nitemare.


Note You need to log in before you can comment on or make changes to this bug.