Bug 116059 - Installing on an existing Volume group does not create /etc/lvmtab
Installing on an existing Volume group does not create /etc/lvmtab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-17 17:45 EST by Forrest
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 17:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2004-02-17 17:45:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I installed FC2 test1 on a machine that had previously been FC1. 
During the installation of FC1, I created a LVM Volume group.  During
the FC2 test1 installation, I created a new LVM partition for /. 
After installation, I ran these:

# vgdisplay
vgdisplay -- ERROR: "/etc/lvmtab" doesn't exist; please run vgscan

# vgscan
vgscan -- LVM driver/module not loaded?

Thus I cannot change my LVM partitions.


Version-Release number of selected component (if applicable):
lvm2-2.00.08-2, lvm-1.0.3-17

How reproducible:
Always

Steps to Reproduce:
1.  Install FC2 test1 on preexisting VG
2.  Create new partition for FC2
3.  Install as normal
4.  Run vgdisplay after installation
Comment 1 Forrest 2004-02-18 16:39:32 EST
I knew that it was probably something easy...I just ran in rescue mode
and found the lvm <command> feature.  I rebooted and tried `lvm
vgdisplay`, and that worked.  We obviously need something in the
release notes about this.

I just tried `lvm lvreduce -L -8G /dev/Volume00/lvol0`, and it
successfully reduced lvol0 by 8GB.  (I actually tried
/dev/mapper/Volume00-lvol0, but it said 'Volume group mapper doesn't
exist')
Comment 4 Peter Backlund 2004-02-28 05:12:12 EST
I installed FC2test1 on two clean discs, creating (among other things)
an LVM2 volume group of two physical partitions, one from each disc.
Setup as follows: 

PV: 100 gigs from hda, 40 gigs from hdc.
LV: 120 gigs for OptLV on /opt, 20 gigs for VarLV on /var.

On first boot, I'm dropped to a shell, since fsck fails. So I
re-install, creating the exact same setup again. Same problem at first
boot. Then I noticed that the /etc/lvm directory and subdirs has not
been created. I then follow the LVM2 initialization steps in
rc.sysinit manually (lines 352-362), which solves the problem and
allows a clean boot. 

This may be an Anaconda problem.          
Comment 5 Alasdair Kergon 2004-04-07 13:43:47 EDT
I'll add a .lvm1 suffix to all the LVM1 binaries - they're no use with
a 2.6 kernel, but some people want them leaving around so they can
reboot back to a 2.4 kernel.

Then I'll update the lvm2 package to install the new versions of the
tools so you don't have to prefix them all with 'lvm'.
Comment 6 Alasdair Kergon 2004-04-08 17:00:20 EDT
Packages updated as described, plus LVM2 tools will invoke the old
LVM1 tools transparently on a 2.4 kernel if required.

lvm2-2.00.11-1.3
lvm-1.0.3-19.0
Comment 7 Alasdair Kergon 2004-04-08 17:09:47 EDT
Peter, the problem you report looks similar to one that's already been
addressed in newer RPMs.  (I think it was fixed in test2.)

Note You need to log in before you can comment on or make changes to this bug.