Bug 1160890 - Button triggered automate actions do not work
Summary: Button triggered automate actions do not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.4.0
Assignee: Aparna Karve
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1161265
TreeView+ depends on / blocked
 
Reported: 2014-11-05 22:28 UTC by Brandon Johnson
Modified: 2015-06-16 12:43 UTC (History)
5 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1161265 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:43:59 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
ruby trace from production log (22.75 KB, application/rtf)
2014-11-05 22:28 UTC, Brandon Johnson
no flags Details
screen shot from cloud forms (218.08 KB, image/tiff)
2014-11-05 22:28 UTC, Brandon Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Brandon Johnson 2014-11-05 22:28:03 UTC
Created attachment 954235 [details]
ruby trace from production log

Description of problem:
When attempting to use a button on a VM/Instance a dialog will not display.  In the log (if there is a dynamic drop down) the automate method that will populate dynamic drop downs runs.  (Attached is the ruby trace from production.log)

Version-Release number of selected component (if applicable):
CloudForms 5.3


How reproducible:
I am able to reproduce this problem on both Infrastructure VMs and Cloud Instances


Steps to Reproduce:
1. Create a button that uses a dialog
2.
3.

Actual results:
displays and error message (screen shot attached)

Expected results:
display the dialog and able to run the method

Additional info:

Comment 1 Brandon Johnson 2014-11-05 22:28:40 UTC
Created attachment 954236 [details]
screen shot from cloud forms

Comment 4 Kevin Morey 2014-11-07 17:16:01 UTC
We need to add the routes for "dynamic_list_refresh" to all classes that allow buttons in the vmdb/config/routes.rb

Comment 5 Kevin Morey 2014-11-07 17:34:19 UTC
This includes:

:catalog
:ems_cloud
:ems_cluster
:ems_infra
:host
:vm_infra
:vm_cloud
:service
:storage
:vm
:vm_or_template

Comment 6 CFME Bot 2014-11-07 22:35:55 UTC
New commit detected on cfme/master:
https://github.com/ManageIQ/manageiq/commit/ccff165f6a59c50ab9e3c470a998da45be5c361b

commit ccff165f6a59c50ab9e3c470a998da45be5c361b
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Thu Nov 6 13:02:45 2014 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Thu Nov 6 13:02:45 2014 -0800

    Added missing route "dynamic_list_refresh" to various controllers
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1160890

 vmdb/config/routes.rb                            | 7 +++++++
 vmdb/spec/routing/ems_cloud_routing_spec.rb      | 6 ++++++
 vmdb/spec/routing/ems_cluster_routing_spec.rb    | 6 ++++++
 vmdb/spec/routing/host_routing_spec.rb           | 6 ++++++
 vmdb/spec/routing/storage_routing_spec.rb        | 6 ++++++
 vmdb/spec/routing/vm_cloud_routing_spec.rb       | 6 ++++++
 vmdb/spec/routing/vm_infra_routing_spec.rb       | 6 ++++++
 vmdb/spec/routing/vm_or_template_routing_spec.rb | 6 ++++++
 8 files changed, 49 insertions(+)

Comment 7 CFME Bot 2014-11-07 22:36:12 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ccff165f6a59c50ab9e3c470a998da45be5c361b

commit ccff165f6a59c50ab9e3c470a998da45be5c361b
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Thu Nov 6 13:02:45 2014 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Thu Nov 6 13:02:45 2014 -0800

    Added missing route "dynamic_list_refresh" to various controllers
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1160890

 vmdb/config/routes.rb                            | 7 +++++++
 vmdb/spec/routing/ems_cloud_routing_spec.rb      | 6 ++++++
 vmdb/spec/routing/ems_cluster_routing_spec.rb    | 6 ++++++
 vmdb/spec/routing/host_routing_spec.rb           | 6 ++++++
 vmdb/spec/routing/storage_routing_spec.rb        | 6 ++++++
 vmdb/spec/routing/vm_cloud_routing_spec.rb       | 6 ++++++
 vmdb/spec/routing/vm_infra_routing_spec.rb       | 6 ++++++
 vmdb/spec/routing/vm_or_template_routing_spec.rb | 6 ++++++
 8 files changed, 49 insertions(+)

Comment 8 Shveta 2015-02-27 22:51:09 UTC
master.20150219134229_64c0205 
upstream_verified

Comment 10 Shveta 2015-03-13 22:15:58 UTC
Fixed .
Verified in 5.4.0.0.11.20150309201930_8b6a235

Comment 12 errata-xmlrpc 2015-06-16 12:43:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.