Bug 116093 - (VM MEM?)kernel panic (with trace)
(VM MEM?)kernel panic (with trace)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-18 01:33 EST by Dams
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 15:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-02-18 01:33:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
Unable to handle kernel NULL pointer dereference at virtual address
00000028
 printing eip:
c017a56f
*pde = 1b60b067
Oops: 0000 [#1]
CPU:    0
EIP:    0060:[<c017a56f>]    Not tainted
EFLAGS: 00010282
EIP is at try_to_release_page+0x2f/0x60
eax: 00000000   ebx: 00000000   ecx: c1337688   edx: c8524204
esi: 000000d0   edi: 00000000   ebp: c8524204   esp: dfdcfd6c
ds: 007b   es: 007b   ss: 0068
Process kswapd0 (pid: 7, threadinfo=dfdce000 task=c1564dc0)
Stack: dfdcfe64 c1337688 c015a9c1 00000000 00000010 dfdcfe4c 00000000
00000001
       c010e795 00000000 00000001 0000001f 00000000 000000d0 c146c278
c1475580
       00000000 00000000 00000000 00000020 00000001 00000000 00000000
00000001
Call Trace:
 [<c015a9c1>] shrink_list+0x721/0x8c0
 [<c010e795>] do_IRQ+0x205/0x340
 [<c015ad66>] shrink_cache+0x206/0x5f0
 [<c015bbc1>] shrink_zone+0x71/0xa0
 [<c015bfb2>] balance_pgdat+0x1a2/0x230
 [<c015c148>] kswapd+0x108/0x120
 [<c0126850>] autoremove_wake_function+0x0/0x40
 [<c0126850>] autoremove_wake_function+0x0/0x40
 [<c015c040>] kswapd+0x0/0x120
 [<c0109295>] kernel_thread_helper+0x5/0x10

Code: 8b 58 28 85 db 75 11 8b 1c 24 89 c8 8b 74 24 04 83 c4 08 e9
 Bad page state at free_hot_cold_page
flags:0x20010014 mapping:00000000 mapped:1 count:0
Backtrace:
Call Trace:
 [<c014fcb5>] bad_page+0x65/0x90
 [<c015079c>] free_hot_cold_page+0x6c/0xf0
 [<c015f1bc>] zap_pte_range+0x18c/0x1d0
 [<c0123751>] schedule+0x391/0x730
 [<c015f243>] zap_pmd_range+0x43/0x60
 [<c015f2a2>] unmap_page_range+0x42/0x80
 [<c015f3d7>] unmap_vmas+0xf7/0x360
 [<c016254e>] handle_mm_fault+0x11e/0x2d0
 [<c0165596>] exit_mmap+0xb6/0x280
 [<c025b1d6>] exit_io_context+0x36/0x90
 [<c0126bfb>] mmput+0x9b/0x100
 [<c012cc60>] do_exit+0x1a0/0x880
 [<c0164b8a>] unmap_vma_list+0x1a/0x30
 [<c016513d>] do_munmap+0x1ad/0x280
 [<c012d3ea>] do_group_exit+0x3a/0x1f0
 [<c011f9a0>] do_page_fault+0x0/0x4cc
 [<c010c49f>] syscall_call+0x7/0xb

Trying to fix it up, but a reboot is needed

I wasnt "really" using the system when it paniced.. I dont know what
really happened. X was started (no dri), screen was off. The system
was not responding anymore to ssh requests and i had to hard reboot it.


Version-Release number of selected component (if applicable):
kernel-2.6.2-1.81

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
Dont know. I'm not clueful enough.
Comment 1 Alan Cox 2004-05-03 15:15:35 EDT
Does this occur with test3 also ?
Comment 2 Dams 2004-05-03 15:25:04 EDT
I did have an hardware memory problem with this system, but i cant
remember if i removed the bad memory before or after this kernel..
But, anyway, it doesnt happen anymore with 2.6.[34] kernels (didnt
upgraded this system to FC2T3 yet). I think we can close the bug..

Note You need to log in before you can comment on or make changes to this bug.