Bug 116095 - (NET 3C59X) Net install fails with 3Com 3c556B - 3c90x
(NET 3C59X) Net install fails with 3Com 3c556B - 3c90x
Status: CLOSED DUPLICATE of bug 107389
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-02-18 02:41 EST by Ed Swierk
Modified: 2013-07-02 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2004-02-18 02:41:28 EST
I am attempting to upgrade to FC2 test1 on a ThinkPad T21.  I boot
from the first binary CD but want to install from the network, so I
run with "linux askmethod" and select FTP.  The built-in NIC (a 3Com
3c556B mini-PCI card) is detected, but when I attempt to obtain an IP
address via DHCP, it times out.

On the F4 console I see the following messages:

<4>3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
<6>0000:00:03.0: 3Com PCI 3c556B Laptop Hurricane at 0x1800. Vers LK1.1.19
<7>PCI: Setting latency timer of device 0000:00:03.0 to 64
<4>  ***WARNING*** No MII transceivers found!
<7>divert: allocating divert_blk for eth0
<7>request_module: failed /sbin/modprobe -- char-major-21-0. error = -16

...

<3>eth0: command 0x3002 did not complete! Status=0xffff
<3>eth0: command 0x3002 did not complete! Status=0xffff
<3>eth0: command 0x3002 did not complete! Status=0xffff
<3>eth0: command 0x3002 did not complete! Status=0xffff

...

The NIC works fine using FC1, kernel 2.4.22-1.2149.nptl.  In
particular, I see the happy message "MII transceiver found at address
0, status 786d" when the driver is installed.
Comment 1 Ed Swierk 2004-04-05 13:49:44 EDT
Same problem with FC2test2, kernel 2.6.4-1.305.
Comment 2 Ed Swierk 2004-04-28 17:12:58 EDT
Same problem with FC2-test3.
Comment 3 Rob Casinghino 2004-05-18 11:04:28 EDT
Same problem with FC2-release
Comment 4 Phil Schaffner 2004-05-20 13:59:09 EDT
Same problem with FC2 final on IBM A21p notebook.  Works with FC1, and
previously with RH7.x, 8.0, and 9.  Would like to know if this problem
persists after non-net install is done before attempting one.
Comment 5 Ed Swierk 2004-05-20 14:03:58 EDT
Yes, this problem affects the installed FC2 system as well as the net
installer.

Disabling ACPI at boot works around the problem and allows the network
interface to be used.  However, in my experience with FC2-test2, this
broke a bunch of other things, including the 1400x1050 framebuffer
console.

I'm sticking with FC1 on my ThinkPad T21 for now.
Comment 6 Doncho N. Gunchev 2004-05-21 20:13:09 EDT
This could be related to bug #107389 if this network card uses
3c59x.ko module in combination with ipv6.ko.
Comment 7 Alan Cox 2004-05-22 12:29:17 EDT

*** This bug has been marked as a duplicate of 107389 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:01:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.