Bug 1160950 - "dnf install foo.rpm" doesn't upgrade "foo"
Summary: "dnf install foo.rpm" doesn't upgrade "foo"
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 21
Hardware: Unspecified Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Radek Holy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1169574 1175310 1177074 1179632 1179720 1190299 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-06 03:10 UTC by Chris Murphy
Modified: 2015-10-06 02:14 UTC (History)
17 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:31 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Murphy 2014-11-06 03:10:28 UTC
Description of problem: Running Fedora 21 with kernel 3.17; downloaded 3.18 from koji and want to install it with dnf, but it refuses with an error that 3.17 is already installed.


Version-Release number of selected component (if applicable):
dnf-0.6.2-1.fc21.noarch


How reproducible:
Always


Steps to Reproduce:
1. Fedora 21 installed with all updates, kernel-3.17.2-300.fc21.x86_64
2. Download from koji to a local directory
kernel-3.18.0-0.rc3.git0.1.fc22
kernel-core-3.18.0-0.rc3.git0.1.fc22
kernel-modules-3.18.0-0.rc3.git0.1.fc22
3. dnf install *rpm


Actual results:

# dnf install *rpm
Package kernel-3.17.1-302.fc21.x86_64 is already installed, skipping.
Package kernel-core-3.17.1-302.fc21.x86_64 is already installed, skipping.
Package kernel-modules-3.17.1-302.fc21.x86_64 is already installed, skipping.
Error: Nothing to do.



Expected results:

These rpms should be installed.


Additional info:

Comment 1 Chris Murphy 2014-11-06 03:13:36 UTC
--debugsolver does nothing, no ./debugdata created.

Comment 2 Chris Murphy 2014-11-06 03:19:09 UTC
I just realized that it's saying 3.17.1 is already installed. I'm running 3.17.2. This error really makes no sense at all.

# rpm -q kernel
kernel-3.17.1-302.fc21.x86_64
kernel-3.17.2-300.fc21.x86_64

Even if I specify the rpms by full name I get the same error message. This works with yum.

# yum install *rpm
Loaded plugins: langpacks
Examining kernel-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm: kernel-3.18.0-0.rc3.git0.1.fc22.x86_64
Marking kernel-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-3.17.1-302.fc21.x86_64
Marking kernel-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-3.17.2-300.fc21.x86_64
Examining kernel-core-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm: kernel-core-3.18.0-0.rc3.git0.1.fc22.x86_64
Marking kernel-core-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-core-3.17.1-302.fc21.x86_64
Marking kernel-core-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-core-3.17.2-300.fc21.x86_64
Examining kernel-modules-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm: kernel-modules-3.18.0-0.rc3.git0.1.fc22.x86_64
Marking kernel-modules-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-modules-3.17.1-302.fc21.x86_64
Marking kernel-modules-3.18.0-0.rc3.git0.1.fc22.x86_64.rpm as an update to kernel-modules-3.17.2-300.fc21.x86_64
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:3.18.0-0.rc3.git0.1.fc22 will be installed
---> Package kernel-core.x86_64 0:3.18.0-0.rc3.git0.1.fc22 will be installed
---> Package kernel-modules.x86_64 0:3.18.0-0.rc3.git0.1.fc22 will be installed

Comment 3 Honza Silhan 2014-11-10 14:22:16 UTC
Chris, can you try "dnf upgrade *rpm", please. For more details about install look at [1].

[1] http://rpm-software-management.github.io/dnf/cli_vs_yum.html#install-only

Comment 4 Chris Murphy 2014-11-11 21:50:24 UTC
upgrade works

Comment 5 Honza Silhan 2014-11-14 13:27:28 UTC
install command discussed here: bug 1138700

Comment 6 Pavel Šimerda (pavlix) 2014-11-14 13:44:10 UTC
Why not mark the bug duplicate instead of NOTABUG?

Comment 7 Honza Silhan 2014-11-18 11:48:29 UTC

*** This bug has been marked as a duplicate of bug 1138700 ***

Comment 8 Radek Holy 2015-02-09 14:23:20 UTC
*** Bug 1169574 has been marked as a duplicate of this bug. ***

Comment 9 Radek Holy 2015-02-09 14:24:43 UTC
*** Bug 1175310 has been marked as a duplicate of this bug. ***

Comment 10 Radek Holy 2015-02-09 14:28:30 UTC
*** Bug 1179632 has been marked as a duplicate of this bug. ***

Comment 11 Radek Holy 2015-02-09 14:31:30 UTC
*** Bug 1179720 has been marked as a duplicate of this bug. ***

Comment 12 Radek Holy 2015-02-09 14:32:28 UTC
*** Bug 1190299 has been marked as a duplicate of this bug. ***

Comment 13 Radek Holy 2015-02-09 14:37:21 UTC
*** Bug 1177074 has been marked as a duplicate of this bug. ***

Comment 14 Radek Holy 2015-02-12 13:04:51 UTC
Fixed by an upstream commit ba535d093bb60b5e115aafe4669a898b2b64e333.

Comment 15 Fedora Update System 2015-03-31 18:18:09 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 16 lnie 2015-04-01 08:35:20 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 works

Comment 17 Fedora Update System 2015-04-02 01:44:25 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2015-04-03 11:39:39 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 19 Fedora Update System 2015-04-06 18:49:31 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2015-04-16 09:04:55 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 21 Fedora Update System 2015-05-08 07:32:53 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.